Azure VM Displaying Incorrect time

Micro90 6 Reputation points

Hi there!

New guys here, I wanted to see if I could leverage the power of the Microsoft community to see if we are able to fix an issue we are having.

We have an Azure multi session VM that's joined to an Azure DC, all of our on prem physical computers are also joined to this DC, all on prem computer are displaying time correctly, DC displays time correctly, Azure Virtual desktop VM is displaying time 1 hour behind, it is driving me insane, running the w32tm /query /source displays the same output as the on prem machines which points to the DC, I have tried syncing and restarting the w32tm service but nothing works!

Does anyone have any ideas what I can try to fix this?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
11,095 questions
Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,243 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Manu Philip 16,711 Reputation points MVP

    Azure VM sets it's time zone as UTC time zone by default. So, it follows the time always until you set a different time zone. I am doing the settings in the following way. Hope, this will help you too
    The steps are executed in PowerShell Commands

    • Open windows PowerShell as administrator in the VM
    • Type the command so that you get the current time zone settings in the VM : Get-TimeZone
      I am expecting the following result


    • Now you need to find the id of your time zone using the command. Note that, you must change the string used as per your location. In my case it is India: Get-TimeZone -ListAvailable | where ({$_.Id -like "India*"})
    • Copy the id shown corresponding to your location and set the new time zone by the command. Here again, change the string id as per your location: Set-TimeZone -Id "India Standard Time"
    • This should immediately change the time to the correct time in the location


    --please don't forget to upvote and Accept as answer if the reply is helpful--

    17 people found this answer helpful.