MFA issue with multiple organisations

Jacob Duijzer 21 Reputation points

Recently I had to re-add my MFA authentication because it was not correctly configured (or that's what they told me). Since I did this, I am unable to login into two other organizations. I have two AD tentants (one from my organization, one I created myself for testing purposes). I also have an AD B2C tenant. When I am logging in into{organization-tenant-id} I am able to login and use MFA. When I want to switch to one of the other organizations, my authenticator app throws an error and I an unable to login.

To verify my identity, when not being able to use the app, I can choose "Approve in app" or use verification code in app, which I can't because of the error. }187637-azure-auth.png

The error in my Authenticator app is: "error finding an account to complete multi-factor authentication. you may need to add the account again".

Is there anyone who can help me in the right direction? I have tried several things but currently I am lost. Tried: disabling MFA in my main account, re-adding my account in the app, rebooted my phone and some other things.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
17,601 questions
{count} votes

Accepted answer
  1. JamesTran-MSFT 34,231 Reputation points Microsoft Employee

    @Jacob Duijzer
    Thank you for following up on this!

    Since you can't access any of your personal tenants, and you don't have any other users that can add additional authentication methods (phone/email) for you. I'd recommend reaching out to our Support Team through an Azure Support Request, if you have this capability within your Organization's tenant, or you can reach out using the customer service number for your country/region.

    For future reference, I'd also recommend creating and managing an emergency access account in Azure AD, this will help prevent being accidentally locked out of your Azure Active Directory (Azure AD) organization because you can't sign in or activate another user's account as an administrator.

    If you have any other questions, please let me know.
    Thank you for your time and patience throughout this issue.

1 additional answer

Sort by: Most helpful
  1. Andy David - MVP 134.1K Reputation points MVP