Azure Cognitive Search query with Semantic search doesn't query semantically

Shahar S 1 Reputation point
2022-03-28T20:55:39.473+00:00

Hey,

What I've done (5 explains the issue):

  1. I've created an Azure Cognitive Search index
  2. I've indexed my data beautifully
  3. I've created semantic configuration
  4. I'm querying the index using the Azure portal, enabling Semantic configuration with the created configuration
  5. I'm getting results that don't include the results I expected if semantic search worked

I'll give some examples:

  1. I have 2 documents, one includes the word "airplane" and the other "airplanes". I assume that when I query, semantically, the text "airplane" or "airplanes", I'll get both documents in each query. But - I get only one document, the corresponding one, in each query.
  2. I have a document with the text "peer companies". When I query the text "top competitors" I don't get this document, although I tried in another semantic search engine and it outputs as the first result.

Best,
Shahar

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
810 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SnehaAgrawal-MSFT 19,596 Reputation points
    2022-03-29T15:54:27.413+00:00

    Thanks for reply! Here suggest you to use language analyzer, as the behavior you are noticing is caused by the analyzer in your search index.

    Using a language analyzer will improve the recall from the inverted index and thus allow semantic search to do a better job.
    So its recommended using the en.microsoft analyzer or the en.lucene analyzer to improve the recall of your queries.

    More details: Add language analyzers to string fields - Azure Cognitive Search

    Further you may refer to the video on below document to see how semantic search is working might be helpful.

    Semantic search - Azure Cognitive Search

    Let us know if further query or issue remains.

    0 comments No comments