Right-click doesn't work on Edge Developer Tools

Kiran Rs 6 Reputation points
2022-03-29T15:42:48.437+00:00

Since the last update, right-click doesn't appear to work in Dev Tools anymore. For example, goto elements and right click anywhere in the HTML area, it's did nothing. I'm using Version 99.0.1150.55 (Official build) (64-bit). I'm a web developer, I would like to fix it asap.

UPDATE - 07/04/2022
I've updated the browser to Version 100.0.1185.29, still the issue exists

Thanks

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,205 questions
{count} vote

2 answers

Sort by: Most helpful
  1. XuDong Peng-MSFT 10,181 Reputation points Microsoft Vendor
    2022-03-30T03:50:33.83+00:00

    Hi @Kiran Rs ,,

    According to your description, I tested this issue and I found that it works fine. Just refer to the result of my test. If possible, you can try to repair Edge or reinstall Edge, this may work for you.

    Just refer these steps to repair Edge:

    1. Make sure that your browser is closed and that you have administrative rights to your device. If multiple users are logged in your device, make sure Microsoft Edge is closed for all users.
    2. Go to Start > Settings > Apps > Apps & features.
    3. In the apps list, select Microsoft Edge and then select Modify. If the Modify command isn't available, it's likely that your organization installed Microsoft Edge and is managing it for you. For help, contact your system administrator.
    4. When prompted Do you want to allow this app to make changes to your device?, select Yes.
    5. Make sure you're connected to internet and select Repair. Your browser data and settings shouldn't be affected by repair.

    Regards,
    Xudong Peng


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Leo Lee 1 Reputation point
    2022-07-19T23:40:43.15+00:00

    @Kiran Rs , if the problem still reproduces in latest version of Edge Stable (version 103), can you share the steps to reproduce the problem (e.g. OS, site, how did you open DevTools?). You mentioned recently you're using Edge 100, can you check if the update actually completed. Troubleshooting steps here: https://support.microsoft.com/en-us/microsoft-edge/troubleshooting-tips-for-installing-and-updating-microsoft-edge-a5eceb94-c2b1-dfab-6569-e79d0250317b.

    0 comments No comments