2 Laptops, remote desktop not accepting password! Please help

Crash Override 1 Reputation point


As a former Microsoft Support Engineer i`m pretty emberrased that this issue got the best of me, but unfortunatly i cannot see where the issue lies.

I have the following setup:
1 PC 21h2 w11pro
1 ROG Laptop 22h2 w11pro
1 XPS Laptop 21h2 w11pro

All 3 machines are logged in using my Gmail address

  1. Connecting the ROG LAtop using mstsc /admin /v:PC logs me in automatically, without asking me for ANY password even after i changed the password for my Microsoft account
  2. Connecting the XPS (newly installed) using the same command line will ask me for a password, which i provide but it does not accept it. I tried just the username, then username@Stuff , then MicrosoftAccount\username@Stuff .com, nothing works!

So i am out of ideas considering the 2 laptops are new, and nothing on the PC changed that could explain this behaivour.
If you guys have any ideas, please let me know.

Thank you,

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,810 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. @CmdrKeene 91 Reputation points

    This is an unfortunate "known behavior" that you have encountered, and Microsoft hasn't yet given a perfect solution for it, but there is still a way to accomplish it. It takes some hoop-jumping.

    In short: on the computer you want to connect to (the remote computer, aka host PC), you must temporarily convert your login to a local user account instead of a Microsoft Account. After setup you are free to convert it back to using a Microsoft Account login and RDP will keep working.

    Here's the explicit detailed steps:

    1) Go to Settings > Accounts > Your Info

    2) Click "Sign in with a local account instead". Windows will show some warnings and suggest you don't do this, but do it anyway. During the process, make sure you set a local username **and local account password** (user accounts with no local password cannot use RDP or Network Sharing).

    3) When done, restart your computer, and try to connect from another of your other machines using the local username & password you set in the earlier step (tou might need to supply the username in the format of remotePCname\username).

    4) Once you've confirmed it works, go back to step 1 & 2, but this time click "Sign in with a Microsoft Account" and finish that process.

    5) Continue using the local username/password to access via RDP.

    If you still can't connect in step 3, here's a tip: open File Explorer and click "network" on the left side. If a yellow toolbar appears, click it and set your network to "Private" in the dialog that opens.

    Please keep me posted with results.

    0 comments No comments

  2. @CmdrKeene 91 Reputation points

    Hello once more, I just found there's an easier method! This user noted that there is a much easier way to do this rather than unlinking & re-linking your accounts. Please check the solution here...


    0 comments No comments