Import azure SQL Database as a database project in visual studio

long 116 Reputation points

when I import azure database to my database project in VS 2019, the table object with identity column has been added 'not for replication'. but I check the original object in database server with sql server management studio, it has not such word. This is a problem that I can not build the project on target platform, Azure SQL database, since Azure SQL does not support it. Why does VS add such word and how can I stop it?

Azure SQL Database
{count} votes

Accepted answer
  1. long 116 Reputation points

    You are right. It does have property, not for replication. But I can not build it with my VS 2019, where the target platform does not have the option for Microsoft Azure SQL Database v12. My VS version is enterprise 2019, version 16.7.2; .net framework version 4.8.03761. How can I get v12 option in VS 2019?

    It seems that vs 2019 does not have v12 option any more. I am able to build it on Azure SQL Database platform by updating SSDT on vs2019

0 additional answers

Sort by: Most helpful