Remote Desktop audio sync issue

Terry 6 Reputation points

I have been using remote desktop for a little over 2 years, using remote microphone and remote sound on my pc

I have an issue where the audio becomes delayed after a few minutes every time (sometimes it happens on startup too) and was wondering if these settings could help fix my issue:



I have tried using audioqualitymode:i:2 and 0 and the issue exists, 0 or dynamic quality is the same as 2 or high quality. Fom the docs:

"The possible values are:


Dynamic audio quality. This is the default audio quality setting. The server dynamically adjusts audio output quality in response to network conditions and the client and server capabilities.


Medium audio quality. The server uses a fixed but compressed format for audio output.


High audio quality. The server provides audio output in uncompressed PCM format with lower processing overhead for latency."


Does that mean high quality sounding audio or the audio is sent in a timely manner? I am trying 1 out now to see if that is working better but are there any other suggestions I can try to make it so the audio is not delayed reaching me?

Thank you

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,332 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Kurt Wong 1 Reputation point

    This problem is so frustrating that I tried the options mentioned above and unfortunately it still didn't work. Despite the fact that there are very many people on the web discussing this problem, there is absolutely no official solution in sight that works.

  2. risolis 8,701 Reputation points

    Hello @Terry , @Kurt Wong and @Toni Lund

    Thank you for your heads up.

    I would like to provide the next links which seems very similar for what you were describing previously.... So please direct yourself down below:

    I hope you can find this useful to overcome your concern and also, review the prerequisites stated on those articles.

    Looking forward to your feedback,


    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments