Azure function VSCode Stuck on Deploying to "XXXX"... Check output window for status ECONNRESET

TiredDev 31 Reputation points
2022-03-31T14:01:57.563+00:00

Hello, after literally nothing, my deployment to my azure functions stopped working, it gets stuck at "Deploying to "XXX"... Check output window for status"
And the console says nothing about it. I've tried so much, with zero success. I'd appreciate any help.

188776-1.jpg

188777-2.jpg

After like 5 minutes, this comes up:
188785-3.jpg

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,512 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,204 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. MughundhanRaveendran-MSFT 12,446 Reputation points
    2022-03-31T14:36:39.34+00:00

    @TiredDev ,

    Thanks for reaching out to Q&A.

    There were lots of issues related to this error message. Could you please try the solution specified in this github issue: https://github.com/microsoft/vscode-azurefunctions/issues/2390#issuecomment-760117050 ?

    Please let me know the outcome.

    1 person found this answer helpful.

  2. Jesper G. Simonsen 1 Reputation point
    2022-04-12T09:45:01.217+00:00

    Same issue here and rolling back to 1.65.2 solved it. Just remember to set the update mode to none for now.

    0 comments No comments

  3. Tommy Tran 1 Reputation point
    2022-04-13T12:40:37.903+00:00

    Follow the Visual Studio Code Azure Functions extension Github issue for the latest details on this bug.

    https://github.com/microsoft/vscode-azurefunctions/issues/2844

    0 comments No comments