Your Spark job requested 8 vcores. However, the workspace has a 0 core limit. Try reducing the numbers of vcores requested or increasing your vcore quota.

Jon-Paul Boyd 26 Reputation points


In Azure Synapse, having an issue executing a Spark notebook. I have checked, using monitor, that no other jobs or notebooks are running.

What I find curious, is that apparently the Synapse workspace should be allocated 50 vcores as default (?), yet the error message from the notebook indicates the workspace has a 0 core limit. How can this possibly be (0 core limit)?

Many thanks for any support as right now I'm unable to progress.

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
3,796 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Merger All 21 Reputation points

    It's a Azure backend issue.
    I request to increase vCore quota per workspace, they feedback in Email of request sumitted successful.
    I tried with no improve during 10 hours afterwards.
    And just now, the issue gone. the notebook can run on my sparkpool successfully.

    3 people found this answer helpful.

  2. Gerben Dam 6 Reputation points

    We have the same issue in all new synapse workspaces on the spark pools, West Europe region. I can not run a single notebook. Just raised a support request. Very annoying!

    1 person found this answer helpful.
    0 comments No comments

  3. Ranjith Abraham 1 Reputation point

    Although I contacted Microsoft Support and got 64 vcores to my workspace, even after 12 hours I cannot run a basic Spark pool cell and the same error comes "InvalidHttpRequestToLivy: Your Spark job requested 28 vcores. However, the workspace has a 0 core limit. Try reducing the numbers of vcores requested or increasing your vcore quota. HTTP status code: 400."

    0 comments No comments

  4. Carl Brown 0 Reputation points

    February 28, 2023. And still the same issues. "Looks like this error is most likely a platform issue." - Microsoft Support.

    They told me to issue a ticket at . But when I do, it says I have to pay $29.99/month to join their support access. I've read all of their online material. These notebooks work sometimes, and sometimes they don't. None are scheduled are used in pipelines. We only have 3 notebooks. I'm not putting that stuff in production if it's not dependable. Makes absolutely no sense to me.

    If Microsoft wants us to use their Synapse Workspace in team settings, where there's a mix of data engineers and predictive scientists, something has to get better here.