Problem with ILMerge after .net framework is updated.

Ansar Shaikh 1 Reputation point

Hi All,
I am facing a challenge while trying to use ILmerge utility inside postbuild commands.

it says "exited with code -1073741819." to avoid this i tried to use ILRepack but still same error.

Then sometimes it says
Program Files (x86)\Microsoft Visual Studio\2019\Professional\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(5578,5): error exited with code 3.

Would be really helpful if any help is given on this point.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
32,699 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anna Xiu-MSFT 20,331 Reputation points Microsoft Vendor

    Hi @Ansar Shaikh ,

    Welcome to Microsoft Q&A!

    Could you share us the complete error message or screenshots? It seems that the ILMerge has been deprecated.

    The error code 3 often means "The system cannot find the path specified". Please check if the path is correct in the Post-build event command line.
    You can try to clean and rebuild your solution.

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments