error intall iss services win server 2022

Abolfazl Roozkhosh 1 Reputation point


Internet Information Services
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Michael Taylor 50,346 Reputation points

    This is insufficient information. Your post says installing IIS but it is clearly already installed on the machine otherwise you couldn't have used MMC to get to it. The error seems to be with starting the World Wide Web service that is part of IIS. Unfortunately there is no way for us to diagnose this given just a screenshot.

    • Did you install the World Wide Web service when you installed IIS? IIS consists of many different pieces and WWW is only 1 part. If you didn't install that feature then it won't be available here.
    • Look in the Event Log and provide us the error(s) that Windows is reporting when trying to start the service.
    • Is the Windows Activation Service running?
    • Try to start the service from a command prompt and report any errors it generates net start w3svc.
    0 comments No comments

  2. Sam Wu-MSFT 7,131 Reputation points Microsoft Vendor

    @Abolfazl Roozkhosh

    There are many reasons for this error, you can try the following solution:

    • Go to Task Manager --> Processes and manually stop the W3SVC process. After doing this the process should start normally when restarting IIS
    • Run -> appwiz.cpl -> Turn windows features on or off -> Uncheck "Internet Information Services" and "Windows Process Activation Service" -> Restart your machine -> Run -> appwiz.cpl -> install both "Internet Information Services" and "Windows Process Activation Service".

    For more solutions, you can refer to the link below:

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments