NC6s_v3 has NO GPU !

Vikram Murthy 6 Reputation points
2022-04-06T08:00:10.537+00:00

We created this VM and nvidia-smi did NOT work and neither did our TF (code) .. CUDA_INIT_ERROR .. so we went ahead and downloaded the latest NVIDIA installer and upon running it, the installer told us that it COULD NOT detect an NVIDIA GPU on the machine. Could some one please shed light on this because as per azure portal this series is supposed to have a 12 GB NVIDIA V100 GPU

Azure Cloud Services
Azure Cloud Services
An Azure platform as a service offer that is used to deploy web and cloud applications.
660 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. kobulloc-MSFT 25,071 Reputation points Microsoft Employee
    2022-04-06T17:27:24.723+00:00

    Hello, @Vikram Murthy !

    Virtual GPU driver installation can be a bit difficult so we've created the NVIDIA GPU Driver Extension for Windows/Linux to install the drivers for you. If you are running into errors trying to install the GPU driver I would recommend using one of the following:

    If you've used one of these installers and you are still running into issues, it's possible that you need a more specific driver installation. Let us know which OS you are using and we can troubleshoot this further.

    Installing Azure NVIDIA VM extensions via the portal:

    1. In a browser, go to the Azure portal.
    2. Go to the virtual machine on which you want to install the driver.
    3. On the left menu, select Extensions.
    4. Select Add.
    5. Scroll to find and select NVIDIA GPU Driver Extension, and then select Next.
    6. Select Review + create, and select Create. Wait a few minutes for the driver to deploy.
    7. Verify that the extension was added to the list of installed extensions.

    190674-image.png

    Installing Azure NVIDIA VM extensions via Azure CLI (Windows):

    az vm extension set \  
      --resource-group myResourceGroup \  
      --vm-name myVM \  
      --name NvidiaGpuDriverWindows \  
      --publisher Microsoft.HpcCompute \  
      --version 1.4 \  
      --settings '{ \  
      }'