VM start, reapply and redeploy fail with a disk related error

Rumen Avramov 26 Reputation points

Hello everyone!
I hope someone can help with this weird issue I ran into.
I have a VM that suddenly began failing to start with this error:

Failed to operationname the virtual machine vmname. Error: The disk/snapshot resource with id resourcegroupname/providers/Microsoft.Compute/disks/osdiskname'>osdiskname cannot be resized down. Reducing disk/snapshot size is not supported in Azure to prevent data loss. If you do need to reduce the size of the disk, please create new snapshot/disks with the appropriate size. More information is available at https://aka.ms/AzureDisksFAQ. Target: '/subscriptions/subscriptionid/resourceGroups/resourcegroupname/providers/Microsoft.Compute/disks/osdiskname'.

This is really unexpected, because there have been no changes to any part of that VM since the last time it worked normally. I tried redeploying and reapplying, but those operations fail with the same error.
Anyone seen something like this or have any ideas?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
5,242 questions
Azure Disk Storage
Azure Disk Storage
A high-performance, durable block storage designed to be used with Azure Virtual Machines and Azure VMware Solution.
415 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Rumen Avramov 26 Reputation points

    Latest update: problem solved.
    What I did was: I took a snapshot of the disk. I created a "dummy" disk out of the snapshot and attached it to the VM. I deleted the original disk and I created a new disk from the snapshot, using the original disk name. I attached this latest disk to the VM and I was able to start it.

    Complete mystery!

    1 person found this answer helpful.
    0 comments No comments