How to fix mixed content error on my WordPress website?

android intensive 1 Reputation point

Hi, I am getting the mixed content error in the Microsoft when I am trying to visit my website. It's build on WordPress. Especially, when I am trying to load the HTTPS, and HTTP content at the same time. I don't know why these issues are arising on my website. Maybe there are some issues with the Microsoft browser. Let me know if anyone else is also facing the same issues. How I can get out of it. I don't think if there are any issues with my website. As its also not working for some other websites as well.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
4,929 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ajkuma 14,931 Reputation points Microsoft Employee

    androidintensive-4075, Apologies for the delay!

    I understand you're trying to load both https and http content, you may review the following config:

    --You could capture a network trace (when reproducing the error) via F12 developer tools in the browser to fetch more details on the error. Also, review Request URL and `Response Headers. Validate to see if https is redirecting to http.

    --In case, you have enforced https on the application level/on Azure Portal, please turn it off and then verify (just to isolate the issue).
    To do this, from Azure Portal> TLS/SSL settings blade, toggle HTTPS Only to Off and then test, and later enable the HTTPs toggle back on.

    --Also, review the configuration Rewrite rules: NGINX Rewrite Rules for Azure App Service Linux PHP 8.x

    Azure App Service on Linux images using PHP 8.x are now bundled with NGINX instead of Apache. The use of .htaccess files will not work for NGINX as these are used for Apache only. This will require the need to setup a custom startup script and modifying the existing NGINX site configuration.

    You may review the log files to fetch more info: https://<yoursite>

    0 comments No comments