Unable to get my RefinableString01 showing inside our PnP Modern search V4 web part's Search filter web part

john john 946 Reputation points

We have a list column of type Choice (inside the built-in SitePages library) which allow multiple selection named Category, as follow:-

enter image description here

and inside the tenant search schema >> i mapped the related crawl property for the Category column, with the RefinableString01 managed property, as follow:-


I issued an index for the SitePages library and for the whole site 2 days ago >> but when i edit the PnP Search Filter webpart (we are using this App https://github.com/microsoft-search/pnp-modern-search )>> the RefinableString01 will not be shown inside the Filter Field drop down, as follow:-


any advice ? what i can do to fix this issue?


A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
10,012 questions
SharePoint Development
SharePoint Development
SharePoint: A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.Development: The process of researching, productizing, and refining new or existing technologies.
2,761 questions
0 comments No comments
{count} votes

Accepted answer
  1. Emily Du-MSFT 43,176 Reputation points Microsoft Vendor

    @john john

    You should go to PnP search results web part -> Edit web part -> In the Selected properties section -> Select RefinableString01 managed property. Then go to PnP search filter web part to select RefinableString01 managed property.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

1 additional answer

Sort by: Most helpful
  1. Anat Dagan | Thomas Lighting 1 Reputation point

    @john john i have the exact same problem. did you manage to solve yours?

    0 comments No comments