SCCM - Trigger App Deploy Eval (User based) by WMIC

David Moon 581 Reputation points
2022-04-07T23:40:12.447+00:00

Hi All
I am having issue trying to run a WMIC to trigger an app deployment eval for an app that is deployed to a user (not machine).
I know this works for a machine based deployment. However, for a user based app deployment, this does not seem to work.
I am using the message ID {00000000-0000-0000-0000-000000000121}.
Looking at the appdiscovery log, i can see the discovery kicking in, when the WMIC command is run. However, the detection is not kicking in for the user based app deployment. It does however, work if i manually trigger the action from SCCM client properties GUI.
Any ideas how i can achieve this, using a command line? I have tried the message ID, 122 and 123, but they give errors.
Thanks, DM.

Microsoft Configuration Manager
0 comments No comments
{count} votes

2 additional answers

Sort by: Most helpful
  1. AllenLiu-MSFT 41,691 Reputation points Microsoft Vendor
    2022-04-08T08:39:48.553+00:00

    Hi, @David Moon

    Thank you for posting in Microsoft Q&A forum.

    According to the documentation, 122 is application manager user policy action, and 123 is application manager global evaluation action.
    What's the error when you tried the message ID 122 and 123?
    191312-1.png


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. David Moon 581 Reputation points
    2022-04-13T07:28:12.13+00:00

    @Jason Sandys @AllenLiu-MSFT

    OK... weird thing is it is now behaving normally now. Dont know what changed, maybe time.... i had two machines which were not working last week, not today, both working. Oh well.
    Thanks for your replies....

    Dave

    0 comments No comments