Cannot create compute instance

Samantha Movius 16 Reputation points
2022-04-08T09:55:04.767+00:00

I'm busy going through the material to prepare for the DP100 Data Science Associate certification. I'm working through the section on Microsoft Azure Machine Learning, and I'm instructed to create a compute instance, but can't create a free one because I don't have enough quota (my available quota appears to be 0) for the required VM (or any VMs for that matter). I haven't created any compute resources yet, so I don't understand why I would have reached any kind of limit already - plus I still have $200 free credit to use. I've also upgraded to pay-as-you-go in hopes that would change something, which it hasn't.

I've also requested a quota increase since that it what has been suggested for some similar posts, but it seems very strange to me that the default would be 0 quota, and that people would be required to request it? Has anyone else had this issue and solved it?

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,657 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Samantha Movius 16 Reputation points
    2022-04-21T06:17:46.413+00:00

    Hi, it's been solved as of 5 minutes ago. Unfortunately you have to request an increase in Quota through Microsoft. I did this on 07/04/22 and it took 8 days before someone got back to me, and then 6 more before it's been solved - so I would do that ASAP if I were you.

    In the meantime, I've cloned the notebooks from the course locally (instead of to Azure ML) and for the most part been able to continue with the material. Good luck!!

    1 person found this answer helpful.
    0 comments No comments

  2. Alexandre Salesse 6 Reputation points
    2022-04-29T16:31:10.09+00:00

    30 days to use credits but need 15 days to get a compute instance. Makes sense.

    I'm bugged and discouraged. Its been 3 days, three FULL days, I'm trying to resolve this, just even get a minimal compute instance to just maybe! learn to use Azure ML. I'm so disapointed. All the videos and documentation make it look so easy, until it's not. I have posted my Quota increase, altho it says 0/12 used. Should I assume I Could use 12 already? However, it's so confusing and demoralizing to learn here this will take up to two weeks just to get such a basic need solved.

    1 person found this answer helpful.
    0 comments No comments

  3. GiftA-MSFT 11,161 Reputation points
    2022-04-08T20:01:33.637+00:00

    Hi, thanks for reaching out. A quota is a credit limit that is shared across all the services in your subscriptions. Limits vary by offer category type, such as free trial, pay-as-you-go, and virtual machine (VM) series (such as Dv2, F, and G). Here's how to manage the Azure Machine Learning compute quota for your subscription :

    • Go to your Azure Machine Learning workspace in the Azure portal.
    • On the left pane, in the Support + troubleshooting section, select Usage + quotas to view your current quota limits and usage.
    • Select a subscription to view the quota limits. Filter to the region you're interested in.
    • You can switch between a subscription-level view and a workspace-level view.

    Raising a support request would be the best way to resolve issues regarding your subscription or service limits. Hope this helps.

    0 comments No comments

  4. vyago 6 Reputation points
    2022-04-20T21:22:25.257+00:00

    Hi,

    I am experiencing the same issue, did you solve it ?

    Thanks.

    0 comments No comments

  5. Samantha Movius 16 Reputation points
    2022-05-02T18:02:56.877+00:00

    I feel your pain, but thankfully you can continue with the content by cloning the notebooks and working locally instead of using ML notebooks on the compute instance. There were a couple notebooks I couldn't work through due to weird package conflicts, but for the most part it was fine. Once I got the quota increase sorted I could go back and run the other notebooks. I hope you haven't been too discouraged to continue, best of luck with the certification!

    0 comments No comments