Azure Synapse Serverless SQL Session Stuck in Rollback

Graeme Cash 71 Reputation points
2022-04-08T15:38:13.84+00:00

Hello

I have created some views on a Dataverse Lakehouse DB created via Synapse Link in a Serverless SQL Database and connected to them via Power BI. Everything has been going ok until I experienced an error during a Power BI refresh. Now there are three sessions stuck in Killed/Rollback that I cannot get rid of. I have tried killing them again and when I run KILL XXX WITH STATUS ONLY it says 'transaction rollback in progress. Estimated rollback completion: 0%. Estimated time remaining: 0 seconds.'

This has happened in two workspaces now and I now cannot drop or alter the underlying views. I'm not sure what I can do now.

Thanks
Graeme

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,558 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Sjaak B 1 Reputation point
    2022-04-09T08:45:02.793+00:00

    'KILL XXX WITH STATUS ONLY' gives error 'Incorrect syntax near 'STATUS'

    But, we are having the same problem on two of our Synapse SQL Serverless environments. It happened before, but then after 24 hours they disappeared, they are in command 'KILLED/ROLLBACK' for days now and blocking new queries.


  2. De Rore, Gilles 26 Reputation points
    2022-04-12T07:02:05.15+00:00

    Having the exact same issue here. Please advise.

    0 comments No comments

  3. Sjaak B 1 Reputation point
    2022-04-12T13:38:00.073+00:00

    We created a ticket with Microsoft and they were able to restart our Synapse environment. They are working on a permanent fix, so it won't happen again.