CPU Usage: 50% or above on all Server 2016 Hyper-V Clustered nodes (5 nodes cluster)

Muhammad Imran 1 Reputation point
2022-04-11T11:10:33.367+00:00

I have created 5 nodes cluster with windows server 2016. If I check CPU usage in cluster it always show 50%. Even if I drain the role and no vm it.

I have 56 intel Xeon Physical core (112 Logical core) on my DELL R640 Server. Below is the result of load percentage.

C:\wmic cpu get loadpercentage

LoadPercentage

100

191810-cpu-load.jpg

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,418 questions
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,600 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 44,071 Reputation points
    2022-04-12T07:55:01+00:00

    Hi there,

    Have you tried running the cluster validation wizard to see if it alerts you to any errors or warnings in your configuration?

    Warnings must be investigated; they often point to issues that need to be resolved, even though they don't prevent the cluster from working.

    Validate Hardware for a Failover Cluster
    https://learn.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/jj134244(v=ws.11)

    Below threads discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue.

    CPU Usage: 50% or above on all Server 2016 Hyper-V Clustered nodes with 3 VM's
    https://social.technet.microsoft.com/Forums/ie/en-US/60d15d03-078e-4502-ae6c-e307a6dfdb64/cpu-usage-50-or-above-on-all-server-2016-hyperv-clustered-nodes-with-3-vms?forum=winserverClustering

    --------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments

  2. Muhammad Imran 1 Reputation point
    2022-04-12T08:48:17.343+00:00

    I have already checked but i didn't find any relevant answer to fix it.

    In this thread they all discus that this problem is due to on servers with more than 64 Logical processors and 2 cpu's. In my case I am using 112 cores on each server.

    This is bug in windows server 2016. I didn't find any fix.

    0 comments No comments