Start Menu Layout via GPO not applying

Christian Africa 1 Reputation point
2022-04-11T22:46:38.317+00:00

Hi guys!

I need your help regarding an issue what I've been experiencing with the GPO Start Menu Layout.

So my goal is to apply a set of shortcuts in our start menu via GPO.

It did work initially on my test machine however after a couple of days as part of my testing, whenever I try to update the XML file that contains the shortcuts, it no longer reflects on the machines.

It only locks it now but the changes I've made on the XML file does not reflect on the start menu for some reason.

Here's what i've done so far for troubleshooting:

  1. Machines are running on 1909 and 21h2.
  2. I can confirm via rsop.msc that it is picking up the correct GPO that sets this start menu layout policy. This is consistent to all of my test machines.
  3. The XML file is on a network folder and "Everyone" has Full Control.
  4. I can confirm that all of my test machines can see the XML file via HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Explorer.
  5. Spelling of the XML file is correct.
  6. I have also tried to remove the XML file and tried to replace it with a fresh copy by doing an export-startlayout - path c:\temp\TestLayout.xml
  7. I have also moved the computer on an OU that does not have restrictions. I scrambled the arrangement of the applications, un-pinned some of them, and placed them back again on the GPO that sets the start menu layout policy. This time what happened is that it locks the group but the applications that should be there, did not get pinned to the group. See attached screenshot.

As per my screenshot, the Teams and Powerpoint icon should be placed to the Microsoft 365 group but it did not get pinned to that group for some reason.

Ofcourse I always do a gpupdate /force for every changes that I do. Sign out and Sign back in again and restart.

Hoping for your immediate assistance.

regards,
Christian191990-layout-not-working.jpg

Windows Group Policy
Windows Group Policy
A feature of Windows that enables policy-based administration using Active Directory.
2,152 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Christian Africa 1 Reputation point
    2022-04-12T01:16:47.107+00:00

    Here is the XML file. I honestly cant see anything wrong with this since it was working previously.

    <LayoutModificationTemplate
    xmlns:defaultlayout="http://schemas.microsoft.com/Start/2014/FullDefaultLayout"
    xmlns:start="http://schemas.microsoft.com/Start/2014/StartLayout"
    xmlns:taskbar="http://schemas.microsoft.com/Start/2014/TaskbarLayout"
    Version="1"
    xmlns="http://schemas.microsoft.com/Start/2014/LayoutModification">
    <LayoutOptions StartTileGroupCellWidth="6" />
    <DefaultLayoutOverride LayoutCustomizationRestrictionType="OnlySpecifiedGroups">
    <StartLayoutCollection>
    <defaultlayout:StartLayout GroupCellWidth="6">
    <start:Group Name="Microsoft Office">
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="1" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\PowerPoint.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="2" DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\Microsoft Teams.lnk" />
    <start:DesktopApplicationTile Size="2x2" Column="3" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Outlook.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="2" Row="1" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\OneNote.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="2" Row="0" DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\OneDrive.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="2" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Skype for Business.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Word.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="1" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Publisher.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Excel.lnk" />
    </start:Group>
    <start:Group Name="Foodstuffs Applications">
    <start:DesktopApplicationTile Size="2x2" Column="3" Row="0" DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\Foodies Service Portal.url" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Endpoint Manager\Configuration Manager\Software Center.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="1" DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\System Tools\File Explorer.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="2" Row="2" DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\Fiori Prod Gateway.url" />
    <start:Tile Size="1x1" Column="2" Row="1" AppUserModelID="Microsoft.ScreenSketch_8wekyb3d8bbwe!App" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="2" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Google Chrome.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="2" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Edge.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="0" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Citrix\Citrix Gateway.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="1" Row="1" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Accessories\Snipping Tool.lnk" />
    <start:DesktopApplicationTile Size="1x1" Column="2" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Acrobat Reader DC.lnk" />
    </start:Group>
    </defaultlayout:StartLayout>
    </StartLayoutCollection>
    </DefaultLayoutOverride>
    <CustomTaskbarLayoutCollection>
    <defaultlayout:TaskbarLayout>
    <taskbar:TaskbarPinList>
    <taskbar:UWA AppUserModelID="Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge" />
    <taskbar:DesktopApp DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\System Tools\File Explorer.lnk" />
    </taskbar:TaskbarPinList>
    </defaultlayout:TaskbarLayout>
    </CustomTaskbarLayoutCollection>
    </LayoutModificationTemplate>

    0 comments No comments

  2. Limitless Technology 37,786 Reputation points
    2022-04-19T07:13:30.247+00:00

    Hi there,

    Have you tried using Import-StartLayout to see if the syntax is correct? If there is anything wrong with the XML file, the CMDLET will give you an error when trying to import it.

    Open an admin command prompt on one of the affected computers and run "GPRESULT /R" to make sure the GPO is in the applied list. If it's in the not applied list, it may give you a reason such as security filtering.

    If it is in the applied list, you can use the admin command prompt to run "GPRESULT /H <filepath>.html" This will create a file you can open in a browser to drill down to the setting and see if a GPO is taking precedence over the one that's not working.


    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments