Publish Multiple Application Pool Using IIS ARR Reverse Proxy

Arief Hardiansyah 51 Reputation points

We've 1 Server application internal with 3 Applications pool inside the IIS Application Pool Settings with details:

-Default Web Site

contoso_A > application that worked & published.

internal url:

Currently we already publish those applications pool using ARR reverse proxy & configured URL Rewrite with external URL
but when we open the external url it shows like the capture below:


Is there any configuration that we missed ?
how to make the external url will direct to application contoso_A ?

Internet Information Services
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,454 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Arief Hardiansyah 51 Reputation points

    Hi @Bruce Zhang-MSFT thanks for your response. Sorry for just replying because it's a national holiday at my place the last few days, the following capture details as you requested:

    Detail bind Information:




    Detail URL Rewrite:




    Here my explanation for current configuration

    For access the application we are using Internal URL:

    and for the goal we want to access the application with an external URL:

    when we access the application using an external URL only the iis page appears (as in the picture above)

    but when we access using external URL we can open the application normally.
    kindly need your help. is there any additional configuration that we have to do?

    0 comments No comments

  2. Bruce Zhang-MSFT 3,736 Reputation points

    Hi @Arief Hardiansyah ,

    This is a default behavior of IIS by design. Please check your rule and url.

    When you use external URL, it matches the rule and host is right. So IIS will route it to server by change the domain to The URI of external URL is empty, so {R:0} is also empty. Then hit on default web site. IIS has a module called Default Document, it will return a specific file when URL doesn't request a specific file. iisstart.htm is the default file IIS return.

    When you use external URL, it matches the rule and {R:0} is PEPS_INTERNAL/Login.aspx. So the URL hits on default web site is which points to login.aspx in PEPS_INTERNAL application.

    The solution I can think of is adding a rewrite rule in default web site to redirect default page.

    1. Disable default document first.
    2. Create a rule at default web site level.
    3. Pattern is ^$.
    4. Rewrite URL is

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best regards,
    Bruce Zhang

  3. Arief Hardiansyah 51 Reputation points

    Hi @Bruce Zhang-MSFT really appreciate your advice.
    where we can set this settings into ? in ARR Server or in Application Server ?
    we will disable the default document, but the order in our IIS is different from yours


    which one should we disable?
    is it default.aspx or default.htm or both?

    we use the ARR server to publish other apps too