Application register

Amparo 1 Reputation point
2022-04-12T14:39:33.473+00:00

I had an application in Azure AD to sync my calendar with my web app (Wordpress + plugin Bookly) but it does not sync now and Azure show this notification: The logged in user is not authorized to fetch tokens for extension 'Microsoft_Azure_Support' because the user account is not a member of tenant 'f8cdef31-a31e-4b4a-93e4-5f571e91255a'. Error details: AADSTS50020: User account '{EmailHidden}' from identity provider 'live.com' does not exist in tenant 'Microsoft Services' and cannot access the application 'c44b4083-3bb0-49c1-b47d-974e53cbdf3c'(Azure Portal) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account.
Trace ID: 329e743f-9667-45f4-888d-89d8307ec700
Correlation ID: f62cf4de-5ce1-4b8b-9de5-fdaec862e041
Timestamp: 2022-04-12 14:34:13Z
I don't understand because I have never created a tenant and it worked correctly.
How I can solved it?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
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  1. Marilee Turscak-MSFT 35,616 Reputation points Microsoft Employee
    2022-04-12T22:23:54.05+00:00

    Hello @Amparo ,

    What action are you trying to complete when you receive this message?

    Error message:

    "Details: AADSTS50020: User account '{EmailHidden}' from identity provider 'live.com' does not exist in tenant 'Microsoft Services' and cannot access the application 'c44b4083-3bb0-49c1-b47d-974e53cbdf3c'(Azure Portal) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account."  
    

    Cause

    There are a number of issues that can cause this error, and I would need further context to know for certain, but often this error is related to subscription access. I will go over several possible causes and solutions below.

    Solution 1:

    This can happen if the account is not part of the Microsoft Services tenant. You will need to sign in with an account that is part of the Microsoft Services tenant and add the XXXXX@harsh.com .com account that is being flagged. Once the account is added, the login should work.

    Solution 2:

    That message can occur if you have a personal "Microsoft" account using the same email address as your O365 "Work or School" account. To resolve this, go to microsoft.com/accounts using an incognito browser so that no credentials carry over, and choose the Microsoft account when logging in.

    You can also try going to the direct tenant link to see if you are able to access it there: https://portal.azure.com/tenantnamehere.onmicrosoft.com

    Solution 3:

    Subscriptions might be located in a directory that you do not have access to. If this is the case, you will need to move the subscriptions to an account that you can access.

    Solution 4

    If your account is locked out of your tenant, you need to ask another global admin for that tenant to let you back in. If you are the only Global Admin for that tenant, you will need to contact the Azure Data Protection team to regain access.

    Solution 5

    This error message can also occur if you have a subscription that is recently expired, inactive, or orphaned. To resolve this, you will either need to claim a new Azure subscription or transfer the subscription to a new account. I would recommend opening a support case for this as you may need internal help to resolve this (depending on which issue this is).

    Here is a link that also provides some helpful information on orphaned accounts. https://learn.microsoft.com/en-us/azure/devops/organizations/accounts/resolve-orphaned-organization?view=azure-devops#:~:text=An%20organization%20is%20considered%20orphaned%20when%20the%20organization,way%20of%20transferring%20administrator%20rights%20to%20another%20user.

    Solution #6
    In some cases can happen if there is a backend outage the Azure side.

    If you provide more details about the actions you are performing when you receive this error, I will be able to better determine the root causes. Feel free to share any screenshots or logs that you might have.

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