Microsoft Photos App Print Button not working.

Vincent Doucet 6 Reputation points
2022-04-12T19:41:05.123+00:00

When using Microsoft Photos you can usually press the printer icon, or "right click > Print" and it will open a menu to select your printer. But instead a black box with a white printer icon flashes very briefly and then disappears. There is no error message, this problem happens on computers using different versions of Windows 10 and on computers that are using completely different installed printers.

I cannot find any error messages in the event viewer about this behavior either. Any suggestions on how to fix this problem, or at least locate an error log that could explain what is going wrong in this process?

Thanks

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,932 questions
{count} vote

4 answers

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2022-04-19T07:40:06.74+00:00

    Hi there,

    If you use your printer, not in the Photo App does it prints without any issue?

    Try the following fix and check if this sorts the issue and if your printer is working fine.

    -Click Start menu > Type Apps & features.
    -Select the app that you want to reset in the list of all the installed apps.
    -Click the Advanced Options link under the application's name.
    -Tap the Reset button to reset an app's settings
    -Once done, check and print in the Photo App.

    This might also be due to registry corruption. The sfc /scannow command (System File Check) scans the integrity of all protected operating system files and replaces incorrect, corrupted, changed, or damaged versions with the correct versions where possible.

    Use the System File Checker tool to repair missing or corrupted system files
    https://support.microsoft.com/en-us/topic/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system-files-79aa86cb-ca52-166a-92a3-966e85d4094e


    --If the reply is helpful, please Upvote and Accept it as an answer–

    1 person found this answer helpful.

  2. Heavy_C 11 Reputation points
    2022-05-02T18:49:03.77+00:00

    Here is a copy of my solution from tenforums, works for my environment. Good luck.

    "I have discovered a solution that has fixed the problem on 7 of the computers at my workplace.

    1. I had to set the user as administrator temporarily, it would not work any other way.
    2. After the user was set as an administrator, I searched "Powershell" right-click and run as administrator. You can also right-click the windows icon in the bottom left corner, and click "Windows Powershell (Admin)"
      2b. When the computer asked for login credentials, I had to put in the username and password of the person who was having the problem, if I tried using the built-in administrator, or a domain administrator, the process would fail.
    3. Run this command

    Get-AppXPackage -allusers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    1. Once the command was run, the users were then able to open Photos and the print menu opened properly.
    2. I removed administrator rights for the users, and the printing continued to work.

    I can only recommend following these steps exactly, I tried deviating at step 2b and the issue would remain. If I was not signed in as the person with the issue, and used their login details at step 2b, the powershell command would not fix the issue. Perhaps someone who understands powershell better than I could elaborate on the problem there.

    The Powershell command selects -allusers and then has a foreach which should install the packages for every user on the PC, but in my environment it did not behave that way, the users would only receive new packages if it was their personal credentials running the command.

    Hopefully this solves your problem."

    1 person found this answer helpful.

  3. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,706 Reputation points Microsoft Vendor
    2022-04-19T07:59:45.947+00:00

    Hi,

    Thank you for posting questions to Microsoft Q&A forum.

    Please kindly first try below troubleshooting steps:

    1. Use Windows Store Troubleshooter

    Settings>Click on Update & Security then Troubleshoot.
    Scroll down to and select Windows Store Apps then hit the "Run a troubleshooter" button.

    1. Reset Photo App

    Click Start menu > Type Apps & features.
    Select the app that you want to reset in the list of all the installed apps.
    Click the Advanced Options link under the application's name.
    Tap the Reset button to reset an app's settings
    Once done, check and print in the Photo App.

    1. Reinstall Microsoft store

    Run PowerShell command as administrator: Get-AppXPackage -allusers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    If all above could not fix the issue, please check in Task Manager if there is a process "PrintDialog" after you click the print button.
    194186-image.png

    Best regards,

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    0 comments No comments

  4. Sabri Baqi 0 Reputation points
    2023-02-27T06:26:14.0066667+00:00

    I faced the same problem in windows 11 and really help me this solution:

    1- go to search bar and type powershell and run it as administrator

    2- write this command or copy and paste and press enter
    Get-AppXPackage -allusers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    then try the photo app again .....you will be happy.

    0 comments No comments