SCCM Http test request failed, status code is 500, 'Internal Server Error'.

Dia 21 Reputation points
2022-04-13T00:05:36.33+00:00

Hi!

I have been asked to help one of my clients with SCCM upgrade issues....
Client upgraded to 2103 and we are now seeing errors in the mpcontrol.log:

Http test request failed, status code is 500, 'Internal Server Error'.
Successfully performed Management Point availability check against local computer.
SSL is not enabled.
Call to HttpSendRequestSync failed for port 80 with status code 500, text: Internal Server Error
Successfully performed Management Point availability check against local computer.

IIS.log

All attempts return ccmhttp - 500 state

When trying to install SCCM client, ccmsetup returns a lot of erros as well and the install does not complete:
GetDirectoryList failed with a non-recoverable failure, 0x87d0027e
Failed to correctly receive a WEBDAV HTTP request.. (StatusCode at WinHttpQueryHeaders: 500) and StatusText: 'Internal Server Error'
Failed to check url HTTP://SCCMVM/CCM_Client/ccmsetup.cab. Error 0x80004005
Accessing the URL 'HTTP://SCCMVM/CCM_Client/ccmsetup.cab' failed with 80004005

Thanks!

Internet Information Services
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,602 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

2 additional answers

Sort by: Most helpful
  1. Dia 21 Reputation points
    2022-04-13T15:10:30.497+00:00

    We have now rolled back and will help with the upgrade planning and prerequisistes.

    0 comments No comments

  2. Limitless Technology 39,501 Reputation points
    2022-04-19T08:06:05.373+00:00

    Hi there,

    The MPcontrol.log and IIS logs (located at W3SVC1) are always best when you troubleshoot SCCM upgrade issues. The error Http test request failed, status code is 500, 'Internal Server Error'. in the log is due failed port 80.

    Check the “SMS Management Point Pool” application pool. Check if Management Point Pool –> Advanced Settings –> Enable 32-Bit Applications was set to TRUE.

    If it is set to true Change the SMS Management Point Pool –> Advanced Settings –> Enable 32-Bit Applications settings to FALSE. Restart the IIS and see if that is helpful.

    You can also follow some general troubleshooting steps from the below thread.
    Understand and troubleshoot Updates and Servicing in Configuration Manager https://learn.microsoft.com/en-us/troubleshoot/mem/configmgr/understand-troubleshoot-updates-servicing

    This thread discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue https://social.technet.microsoft.com/Forums/en-US/9be1f311-2344-4a58-b038-974a1aa34015/mp-controllog-error-http-test-request-failed-status-code-is-500-internal-server-error?forum=configmanagergeneral

    --------------------------------------------------------------------------------------------------------------------------------

    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments