Usb drive unable to be used in createing a pool in storage spaces

Shae Lyday 1 Reputation point
2022-04-13T02:19:35.057+00:00

I just got my pc and haven't been able to us it due to the frequent low disk storage went out and bought 2 external usb drives bcuz after doing a little research on google I thought i would b able to create virtual space with them. Of course, I was wrong an with additional hours looking for an answer so i can save my art, in a forum from 2019 i found the truth the Storage space does NOT work with usb drives. Can I please get professional advice? How do I increase my storage?

Windows Server Storage
Windows Server Storage
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Storage: The hardware and software system used to retain data for subsequent retrieval.
640 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,476 Reputation points
    2022-04-19T07:44:42.907+00:00

    Hi there,

    Generally, Storage Spaces on Windows cannot use USB flash drives.

    The problem is the "Removable Disk" status of the flash drives. Windows don't let "Removable Disks" become part of the storage spaces pool. Thus this is all you need to solve, convert all your USB Flash drives from "Removable" to "Fixed".

    You can try the below steps and see fi that helps you

    -In Device Manager find the external drive under Disk Drives.
    -right-click the drive and go to Properties
    -Go to Policies
    -select Better Performance
    -select Enable write-caching on the device
    -select Turn off Windows write-cache buffer flushing on the device

    Once these steps are done check if you can create a storage pool using the USB.If you need to free up some space here are some suggestions https://support.microsoft.com/en-us/windows/free-up-drive-space-in-windows-a18fae02-a0fa-8df9-9838-8970f9939de4


    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments