Unable to RDP to Windows 2012 R2 from Mac

Owen Air 1 Reputation point
2022-04-13T12:42:43.077+00:00

I'm having problems using the latest RDP client from the app store and RDP'ing into a 2012 r2 RDS server.

The window opens and says "configuring session" but then on the mac's screen it closes.

Oddly the session stays open for a short time then tries to subsequently reconnect and eventuall disconnect.

On the RDGW the information message is displayed The Desktop Window Manager has exited with code (0xd00002fe)

I've tried 3 different Mac's to the same server and i've tried 2016, 2019 & 2022 which work fine.

it just appears to be W server 2012 R2

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,556 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,335 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2022-04-20T07:56:57.673+00:00

    Hi there,

    "The Desktop Window Manager has exited with code (0xd00002fe)" indicates that the RDP connection was disconnected and not that the user ended it using logoff.

    The reason you might get this error is that you might be using a newer version of the remote desktop than what the remote computer is using to connect regardless of any authentication process, set your remote desktop client to connect even if there is no authentication.

    On Remote Desktop go to Options then click on the Advanced tab and under “if the actual verification does not meet minimum policy requirements” choose Connect and don’t warn me.

    Below threads discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue.

    https://social.technet.microsoft.com/Forums/windows/en-US/0b865c92-5e0b-4518-9092-790aed895f5b/remote-desktop-connection-for-mac-os-x-cannot-connect-to-windows-81


    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments

  2. Owen Air 1 Reputation point
    2022-04-20T08:01:24.373+00:00

    Hi There,

    I managed to do a workaround to this problem by publishing the remote desktop as a workspace via the registry.
    For some reason workspace on the Mac app worked fine but RDP to the server didn't.

    https://ryanmangansitblog.com/2014/01/04/publish-remote-desktop-session-in-a-remote-app-session-collection/

    0 comments No comments