Exchange Hybrid Mailbox Migration MRSProxy Failed

Namless Shelter 216 Reputation points
2022-04-15T00:52:15.453+00:00

Dear Friends,

We are having some issues with our hybrid Exchange environment (Online Exchange, On Prem Exchange 2016 and exchange 2010.)

I was planning to migrate some old mailboxes from Server 2016 to the cloud. It failed with "GUID.resource.mailboxmigration.his.msappproxy.net' could not be completed. Everything else, mail flow, SMTP is working fine.

I checked several things on the on prem servers, seems to be all fine. EWS is all on, and Migration Endpoint is still there. MRS proxy servers configured for both on Prem exchange servers.."

The only thing is that Exchange server 2010 was powered off last year (It used to be main mail server before setting up hybrid). We renewed SSL beginning of this year. The old server 2010 has been renewed with the latest SSL wildcard certificate. I noticed on EWS for Exchange 2010 server, MRS proxy enabled with basic authentication ticked.

Would "Expired SSL on old exchange server" be the reason why Migration failed? Is there any way we can troubleshoot this issue?

I tried disabled and enabled MRS Proxy on old server, restarted IIS, still no luck..

Help please.
Thanks
ML

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,307 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,951 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Amit Singh 4,861 Reputation points
    2022-04-18T09:21:39.19+00:00
    0 comments No comments

  2. Dimik 0 Reputation points
    2023-02-27T14:24:30.2366667+00:00

    If you run the command Get-WebServicesVirtualDirectory | select auth you’ll find that (most likely) Basic Authentication is set to $FALSE. To set this to $TRUE and thus enable Basic Authentication you can use the following command:

    Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory –BasicAuthentication $TRUE

    0 comments No comments

  3. philip van Klink 5 Reputation points
    2024-04-03T20:08:16.8433333+00:00

    We had the same error. As we were using Exchange 2019 CU14, Exchange Server Extended Protection was turned on. I had to turn Extended Protection off in IIS (EWS). It can be done via script also. More info here: https://practical365.com/exchange-server-extended-protection/

    I had to set up the Migration End point again by re-running the HCW choosing Modern Hybrid Topology

    User's image

    0 comments No comments