Microsoft XNA failure to load pipeline

Max Taunton 1 Reputation point
2022-04-15T16:36:39.627+00:00

FULL ERROR:

Error loading pipeline assembly "C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework.NETFramework\v4.0\Microsoft.Build.Framework.dll". XNA

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

When I try to build the program with any files in the content folder (such as "Player.png" in my case) I get this error every time I run it. Is there a solution for this or am I doing something wrong?
193449-image.png

C#
C#
An object-oriented and type-safe programming language that has its roots in the C family of languages and includes support for component-oriented programming.
10,528 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. P a u l 10,411 Reputation points
    2022-04-15T18:04:40.933+00:00

    If you register the Microsoft.Build.Framework.dll in the MSBuild folder that's bundled with your version of VS into the Global Assembly Cache does that fix the error?

    So if you had 64-bit VS Community 2022 the path containing this assembly is C:\Program Files\Microsoft Visual Studio\2022\Preview\MSBuild\Current\Bin

    If you open "Developer Command Prompt for VS 2022", then run "cd C:\Program Files\Microsoft Visual Studio\2022\Preview\MSBuild\Current\Bin"

    Then run "gacutil /i Microsoft.Build.Framework.dll"

    If you have a different VS installation you'd need to update the path above.

    1 person found this answer helpful.

  2. Tom Zeiler 1 Reputation point
    2022-11-16T06:31:11.947+00:00

    Just ran into the same problem, and your answer solved it, so thanks from me as well!

    0 comments No comments