MDT Offline Media Doesn't Install Intel Ethernet Driver

Bron Hafner 21 Reputation points
2022-04-15T23:31:14.517+00:00

PROBLEM

I am trying to create a USB flash drive to install a custom image from MDT to a couple of models of Dell laptops, but I can't get it to install the Intel network driver on at least one model (I haven't tried the other model).

BACKGROUND

I am a one man IT department and new to Microsoft Deployment Toolkit (MDT). I have set up MDT on a workstation computer in my remote office, but we don't have an actual deployment server. I have a bunch of new and old computers to configure, and my goal is to be able to deploy from a USB flash drive. Most of the new computers are in our main office, while the MDT machine is in my remote office.

I have been slowly working through various problems and got everything working on an old Dell Latitude 5480 laptop. Now I'm trying to test things on a new Latitude 5420. We also have a few old 5400's but I have not tried with one of them yet.

DETAILS

I have my Out-of-Box Drivers set up like this now:

Windows 10 x64
Dell Inc.
Latitude 5400
Latitude 5420

I have imported drivers from the latest CAB files to each of these. At the moment, I have a selection profile that points to the Latitude 5420 folder, and my task sequence is set to inject drivers from this profile. (This setup is for testing at this point.)

When I install from the USB drive to the 5420, everything works except that the driver is not installed for the Intel Ethernet Connection I219-V network adapter and thus the machine has no Internet access. All other drivers and applications install except those dependent on the Internet. I'm not trying to join it to a domain yet.

OTHER NOTES:

  • The network driver does seem to work in Win PE. If I break out to a command prompt after booting from the USB drive, I can ping out.
  • After the installation finishes and the machine has no network access, I can update the driver in Device Manager by pointing to the driver on the MDT USB drive, and it installs fine.
  • I tried downloading drivers directly from Intel, but this didn't work either.
  • My setup had worked fine with a different machine (a Latitude 5480), so I don't think it is something else with the general setup of MDT.
  • I don't know where to find any log files that would indicate the issue, if there are any. I couldn't find any on the USB drive, and without network access, it couldn't write to a share someplace in any case.

WHAT NEXT?

At this point, I'm not sure what to do. I've invested a lot of time trying to get this working, but if I can't connect to a network after installing, this whole MDT thing won't be saving me a lot of time.

Anyone have any ideas?

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
845 questions
0 comments No comments
{count} votes

Accepted answer
  1. AllenLiu-MSFT 41,691 Reputation points Microsoft Vendor
    2022-04-18T07:19:30.473+00:00

    Hi, @Bron Hafner

    Thank you for posting in Microsoft Q&A forum.

    We may check ZTIDrivers.log for driver injection issue.
    If the task sequence has finished, look in %WINDIR%\TEMP\DeploymentLogs. MDT will move everything there at the end.
    You may compare it with the log of Latitude 5480.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1 additional answer

Sort by: Most helpful
  1. Bron Hafner 21 Reputation points
    2022-04-19T22:04:55.613+00:00

    Well, I finally got things working, but I'm not sure exactly what I did! I'll explain some details in case it helps anyone in the future.

    I was helped by the following TechNet post about debugging missing drivers in MDT:

    https://social.technet.microsoft.com/Forums/en-US/3e083173-f5db-48e9-b744-f71b9ca6541c/how-to-debug-missing-drivers-in-mdt

    Following guidance in Step 3 of that post, I found the hardware IDs for my NIC in Device Manager. I noticed that these did not show explicitly in the .INF file for the driver I had for the NIC. I also found the following line in the setupapi.setup.log file referenced in Step 5 of the post:

     !    set: PCI\VEN_8086&DEV_15FC&SUBSYS_0A201028&REV_20\3&11583659&0&FE -> Configured [null] and unstarted with problem CM_PROB_FAILED_INSTALL (28) [0xC0000490] (ConfigFlags = 0x00000040).  
    

    Searching on the web, I found this page from Microsoft:

    cm-prob-failed-install

    All the evidence at this point indicated that when MDT was trying to inject drivers into the OS, it couldn't find compatible drivers even though they were on my USB offline media. So I installed the driver manually from the USB drive after MDT setup was finished, and then exported all drivers from the machine, imported them into MDT, and started the process again. But installation on the Latitude 5420 again failed to install the NIC driver. I tried on a Latitude 5400 (with it's own drivers), and it worked fine.

    So I gave up and inserted a "suspend" action in my task sequence just before the "Recover from Domain" task. The idea was that I would manually install the network driver when the task sequence was suspended, then resume the sequence, and now that the network was connected, the "Recover from Domain" task would then join the domain (or I could add a script to do this).

    The bizarre thing was that when I tested this and the task sequence was suspended, the network driver had already been installed! This was the first time it had worked after many, many attempts, and I have no idea why. I wonder if in my last attempt I had failed to update the deployment share or something, but I'm pretty sure I did.

    In any case, it is working now, and I left the "Suspend" task in to verify the network (and other) drivers are installed before the task sequence finishes. I hope no one else ever runs into this!