MSVCP140.dll and VCRUNTIME140.dll not found

Dakota Gansen 1 Reputation point
2022-04-16T17:11:16.747+00:00

I noticed that my Sims 4 game was lagging so I decided to do a full reset on my Acer Aspire A115-31 laptop. Now that I've tried to reinstall Origin, I get the "The code execution cannot proceed because VCRUNTIME120.dll was not found." and "The code execution cannot proceed because MSVCP140.dll was not found." I have tried to download the files and reinstall Origin. Nothing changed. I've tried to put the MCVCP file into my windows systems file on my file explorer and trying to open Origin as an administrator and nothing has worked. Please help... 64-bit operating system, x64-based processor on Windows 11.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,604 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Andreas Baumgarten 99,371 Reputation points MVP
    2022-04-16T17:44:23.947+00:00

    Hi@Dakota Gansen ,

    both dlls are part of the Visual C++ Redistributable Packages. If the files are missing you could download and install the Visual C++ Redistributable Packages.
    https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten