Multiple Apps in Azure App Access Panel with one Enterprise App for SSO

Graham Bird 1 Reputation point
2020-02-03T17:04:31.12+00:00

We have on-prem SAP system that has been configured for SSO in Azure AD Enterprise App and is working, a Tile shows in the Azure App Access Panel / MyApps / O365 App launcher, which users can click on to get to it.

The SAP team are now asking if its possible to setup an additional application to appear in the App Access Panel that uses the existing Enterprise Application for SSO?

From my experience so far you cant add another Enterprise Application that users the Same SSO Identifier and if i setup an app registration using the URL they want to SSO to it just throws an error that is not very helpful.

"You cannot access this application because it has been misconfigured. Contact your IT department and include the following information: Undefined Sign-On URL for application "SAP - WebGUI"

Looking in the App Registration settings I cant see any where to configure the Sign-On URL...???

Any ideas?

Thanks,

Graham

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,148 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. KAREDD-MSFT 406 Reputation points Microsoft Employee
    2020-02-04T00:20:33.393+00:00

    If your application is using SAML protocol, then you have to register it as a non-gallery app as described here : https://learn.microsoft.com/en-us/azure/active-directory/manage-apps/add-non-gallery-app.

    After creating an app, to configure the SAML single sign on settings follow the steps listed here : https://learn.microsoft.com/en-us/azure/active-directory/manage-apps/configure-single-sign-on-non-gallery-applications

    Note: You can definitely have your custom apps listed in the my access panel. However, Identifier will have to be unique within your Azure AD tenant.

    1 person found this answer helpful.
    0 comments No comments