SSL certificate import issue within IIS on window 2016 server

Matt Gates 1 Reputation point

Hi, all. Hopefully I'm posting this to the right group.

As of the 19th April we are experiencing problems importing SSL certificates into IIS. We have three 2016 Windows servers and this issue is happening on all three. 

We get the error below when importing after adding the password.


Done all the obvious stuff re checking passwords etc.

This has happened now on three separate domain SSL's.

We are using GEO Trust Quick SSL Premium SSL's. 

Our hosting company have the same problem when they tried, they don't have a solution either. 

We are assuming this might have been caused by a recent Windows update?

Anyone have any ideas or experienced this?

Internet Information Services
Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,969 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Matt Gates 1 Reputation point


    Thanks for coming back to me I appreciate your help.

    I have tried importing the .pfx certificate into MMC directly, it won't accept the password. The password is definitely correct, I have done this many times.

    Please see the screenshot below.


  2. Limitless Technology 37,771 Reputation points

    Hello MattGates,

    This may be related to a change in permissions at the NTFS level on the storage where IIS is installed.

    I will recommend you to follow the steps on this troubleshooting guide:

    Hope this helps with your query,


    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  3. Matt Gates 1 Reputation point


    Thanks for your answer. This didn't help unfortunately.

    We have three 2016 servers all have the same problem trying to import GEO Trust certificates created via our IONOS admin. They import older valid certificates created last month just not new ones created this week.

    The new certificates work on our other 2018 windows server. So this seems to be a problem with 2016 windows servers and certificates created this week.