Teams Call Queue showing 0 Agents

Kevin Still 21 Reputation points


I follow the documentation and video Microsoft provided on creating a call queue in Teams.

My goal is to create an internal call queue only, no phone number yet. We just want to test it and see how it works for us.

I created a resource account and assigned it a Microsoft Teams Phone Standard - Virtual User license.

I created a Call Queue and linked it to the resource account and then I linked it to the Team and the Specific Channel.

It shows 0 Agents for the call queue and calling it just plays the music... nothing rings.

What am I doing wrong?

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,587 questions
0 comments No comments
{count} votes

Accepted answer
  1. JimmyYang-MSFT 50,446 Reputation points Microsoft Vendor

    Hi @Kevin Still

    Please check if you meet these requirements below when creating call queue in your organization:

    Based on my knowledge, Agents who receive calls from the call queues must be Enterprise Voice enabled online or on-premise users. In addition, if the call queues are using Direct Routing numbers, agents who need to conference or transfer calls also require:

    • An online voice routing policy assigned if the call queue uses transfer mode
    • An Audio Conferencing license or online voice routing policy assigned if the call queue uses conference mode

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

1 additional answer

Sort by: Most helpful
  1. Kevin Still 21 Reputation points

    That was the correct answer, I didn't think they needed enterprise voice since they don't have any number attached.

    The one issue I am having is getting the call queue/resource group to show up in the teams search bar.

    0 comments No comments