HLK Fail: Enable Cluster Functionality and S2D Tests

Technically Tony 1 Reputation point

I'm stuck.


Running hard drive S2D certification testing and it fails at the same place every time - per HLK Manager it fails at the: "Enable cluster functionality and S2D tests" part.



Secondary Findings:
When I issue the command detailed in the root cause manually on the PCS I get this error:

Things I've done:

  • confirmed wsman functionality
  • confirmed the LogModule.psm1 is imported
  • confirmed existence of LodModule.psm1 in the specified HLK directory
  • removed PCS from the domain and added it back (hence the ".000" on the end of the name in the screenie)


  • DC and HLK are Server 2019
  • PCS and Nodes are Server 2022
  • Account being used is a domain admin

All nodes show 'Online' in Server Management and Cluster Validation test passes without issue.

Experiencing the same issue in two newly built seemingly identical environments (both built within the last week from bare metal up). Screenshots are a mix of the two environments so if the node names don't jive, that's why. Experiencing the exactly same symptoms in both places though.

Windows Hardware Performance
Windows Hardware Performance
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.Hardware Performance: Delivering / providing hardware or hardware systems or adjusting / adapting hardware or hardware systems.
1,577 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Technically Tony 1 Reputation point

    Followup: I cautiously say I've resolved this issue and am posting my fix for those that come after me. Should you encounter this set of symptoms, mostly likely remote powershell is not enabled. The following commands will allow the scripts to function as designed.

    Execute on nodes and controller(PCS).

    CMD (run as admin):
    winrm.cmd quickconfig

    PS (run as admin):
    powershell.exe enable-psremoting -force
    powershell.exe set-executionpolicy RemoteSigned -force

    YMMV but it worked for me.

    0 comments No comments