Resource not found on notification hub under portal and az client

Jake Hätinen 116 Reputation points
2022-04-23T14:05:49.837+00:00

I have an notification hub namespace that contains currently 2 notification hubs.

One has been in use for some time now. I raised the namespace tier from free to basic and after that i discovered that I cannot access that hub under notification hub namespace anywhere.

It is not visible if I look at https://portal.azure.com/#blade/HubsExtension/BrowseResource/resourceType/Microsoft.NotificationHubs%2Fnamespaces%2FnotificationHubs

But I can see it under the notification hub namespace. But from there if I click it Resource not found error appears.

Same happends with the az cli. list command shows the hub but when trying to call update for that hub => Resource not found error.

Also if trying with AZ test-send to that hub, it also replies with resource not found.

Azure Notification Hubs
Azure Notification Hubs
An Azure service that is used to send push notifications to all major platforms from the cloud or on-premises environments.
180 questions
{count} votes

Accepted answer
  1. ajkuma 15,031 Reputation points Microsoft Employee
    2022-04-27T18:35:26.757+00:00

    To benefit the community, sharing our offline/private discussion.

    We were able to resolve the issue after performing a sync operation on the subscription.

    Thanks for your collaboration in solving this issue @Jake Hätinen

    --The possible cause for this issue is due to ARM sync issue. The missing resource was also not visible on Azure Resource Explorer.
    Steps to validate this:

    1. Navigate to Azure Resource Explorer
    2. Search for the missing Azure resource
      --for a detailed steps on use-the-azure-resource-explorer

    --
    To benefit the community find the right answers, please do mark the post which was helpful by clicking on Accept Answer’ & ‘Up-Vote’.

    0 comments No comments

0 additional answers

Sort by: Most helpful