[SQL Server Agent] Packages in SSISDB not visible, SQL Server Authentication + Proxy

Lam Hoi 1 Reputation point

Hello, I have been struggling with setting up a SQL Server Agent Job for SSIS package.


  • Server A: SQL Server 2012 (MSSQL Server Management Studio)
  • Server B: Java application
  • Tools: Visual Studio 2019 Community (for implementing SSIS packages)

In server A, by using a domain admin account (with Windows Authentication), I could deploy my SSIS packages to "Integration Services Catalogs -> SSISDB -> XXXX folder":
They could be executed successfully by "Right Click -> Execute".

Now I would like Server B's application to connect to Server A with "SQL Server Authentication" and trigger those packages. I learned that DB accounts with "SQL Server Authentication" cannot deploy and execute packages in SSISDB. A proxy account is needed. So the follows are what I have done:

In server A, by using a domain admin account

  1. Create "Proxy Credential"
    with ID & PW exactly the same as the domain admin's
  2. Map the "Proxy Credential" to the account Server B is using(sa or tempuser)
  3. Create a proxy for subsystem "SSIS Package Execution"
    1. Create a new job under "SQL Server Agent"

But then I encountered a problem: the deployed project/package(s) are not visible

Is there any permissions/authorities of I am missing?

Besides, I am still a beginner of SSMS. Is there any other ways to achieve my goal?

Thank you so much.

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,523 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ZoeHui-MSFT 35,546 Reputation points

    Hi @Lam Hoi ,

    As the image shown, when you connect serverA in serverB, it is success and we could see the ssis packages in the SSISDB.

    When you configure the agent job, please make sure the server you choose is serverA.


    If I misunderstand your issue, please incorrect me.



    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.