Azure API management gives 404 error

Subin Pius 1 Reputation point

I am trying to configure an API which is in private cloud in API management.
But I always get 404 error, resource not found.

Then I tried with simple API which is available in internet and tried to configure it in the API management.
But still I get the same 404 error. Its a GET request without any authentication.

Testing in Azure Portal is also giving the same error for the API's


Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
1,234 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. MayankBargali-MSFT 54,456 Reputation points

    @Subin Pius Thanks for reaching out. 404 error means that the URL was incorrect. There could be two reasons for 404 errors

    • Your APIM URL is correct, but APIM was not able to find your backend service/or the path is incorrect/backend service not accessible over internet/within network, and it returns 404 error.
    • Your APIM URL is incorrect where the path was not resolved correctly, and it returns 404 error.

    I will suggest to you to test the APIM API's either from developer portal or from azure portal APIM instance to validate if your APIM URL that you are using in your fiddler/postman is correct or not. This test will eliminate the second reason that the APIM URL is incorrect.

    If your APIM URL is correct, then you can review the OCP APIM trace that will verify whether the error is returned when APIM is not able to find the configured backend service or not.

    In case if you are not able to find the root cause then please let me know so I can connect offline and verify your APIM configuration to assist you further.