Hyper-V problem after add 10 VMs

Steph 1 Reputation point
2022-04-27T08:34:41.52+00:00

Hi,

We have buy a new AMD (EPYC 7413 24-Core Processor + 512 Go de RAM and Full SSD) server (we working with intel only before) but we want to try AMD...
We have installed Windows Server 2022 on this server (all other Hyper-V (x4) server are on Server 2016)

Yeterday, I have to rollback my migration because after move 10 vm hyper-v on this new server, it had become unstable :

Can’t control VM at all (if they are online, I can’t stop it for example, and some of them who are stop can’t be start.. I have status stuck on « starting… »), it’s like the vmms it’s completely stuck (I tried to restart the process (vmms service) many times, but doesn’t work)...

If I restart the whole server the process works again I can start VM fine but after few minutes it’s broken again… I'm loosing the control of the VMs.

I can't open settings parameters of VM for example.. Need to restart whole server again to retake the control..

At the first time, I was thinking that a VM in the lot crashed Hyper-V (I had the problem once on another server, but It was not exactly the same symptoms, I was not able to launch console for example in this case...).
It was a VM with a network card who cause the issue, and I had to delete the card and add a new one.. I'm wondering if it's not the case again... I have found a similair problem on a website, the user had a BSOD caused by linux VM on a AMD server.. No BSOD in my case however.

In the problematic server, I have found warning info in the log many times :

VMs Utilization Plan Vport QueuePairs adjusted from the request number 16 to real number 4.
Reason:
The number of requests exceeds the maximum number of QP per VPort supported by the physical network.
Event ID => 280

I found nothing on the web about this event, do you what is it ? The time log seems to fit the problem.

I have planned to reinstall the whole server in Windows server 2019 and reinstall hyper-V role to know if it's caused by a sort of incompatibility between OS and drivers ? I didn't find drivers for Windows server 2022 and I'm wondering if it can be the problem.

If you have any idea...

Thanks again !!

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,617 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Anonymous
    2022-04-27T12:57:22.24+00:00

    didn't find drivers for Windows server 2022 and I'm wondering if it can be the problem

    Yes, likely is the problem. I'd check here and with the manufacturer about support for Server 2022.
    https://www.windowsservercatalog.com/

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. Jamie C 1 Reputation point
    2022-05-12T10:56:34.65+00:00

    I had basically the same issue with a system using 2x AMD EPYC 7302 16-core processors but I could only get to 5 VM's before it would not work, tried all kinds of things, removing the virtual switch, turning off Hyper-V allow NUMA spanning. Once I started them up manually in a different order and I managed to get to 6 then it went wrong again.

    I also didn't have any host crashing, BSOD etc but as soon as I tried to start the 6th VM I couldn't stop it starting, access settings for any of the VM's etc, everything just stopped working.

    I wiped and put in Server 2019 and it all started working straight away, got 10 running no issue.

    The only other difference between when I was using 2022 to when I was using 2019 was that I had to use a PowerShell created Hyper-V teamed virtual switch rather than just use the server windows teaming......when I went back to 2019 I used the windows teaming method that works fine for us.

    I don't think that was the issue but worth mentioning, the issue for me feels like the combination of an AMD processor and Server 2022. I have to say my experience with AMD processors in servers is that it always adds unnecessary pain, sadly the more expensive Intel Xeons just work. (the first PC I built had an AMD K6-3....so i've worked with them for a long time too)


  3. CoreyPL 11 Reputation points
    2022-10-10T09:44:42.943+00:00

    Hello,

    I was facing the same Windows Event ID = 280 on new DELL PowerEdge R7515 (AMD 73F3 based) and Windows 2022 Server.
    I got this error even before creating any VM. It started to show just after I added Hyper-V role and configured first vSwitch.
    I am using separate Broadcom NetXtreme E-series 10GB SFP+ 2-port card dedicated for VMs and it was giving me the problems.
    What helped me was the driver update. Dell still had almost a year old drivers for this card as the latest. I've downloaded the latest ones from Broadcom directly, that were dedicated for Windows 2022 (223.0.157.0 at the time of writing) and all errors went away. No more Event ID 280 error, no more NDIS capture vSwitch plugin error.

    I hope this helps anyone facing the same problem with the Event ID 280 error.

    Cheers
    Piotr

    0 comments No comments