Can't access shared folders on Windows Server 2012

ticbx 1 Reputation point
2022-04-27T13:45:06.147+00:00

I cannot access shared folders on a private network, even from the server computer with an administrator account.
This is going on for about 2 days, and I have searched many similar issues online without any progress on solving the problem.
I will list bellow what I have found so far that seems to be the most relevant.

During troubleshooting I tried to create a new shared folder from the Server Manager and the following is happening:

196947-new-share-wizard-error.png

However, when I create the share from the folder properties in the file explorer, the share is created, and can be seen in Server Manager.

197043-new-share-from-folder.png

197016-share-showing.png

When inspecting the properties of the shared folders the following error also occurs:

197024-properties-error.png

In the server computer I can see all the shared folders when opening \servername.
When I try to open any folder, from the server or from a remote computer, the following error occurs:

197062-shared-folder-error-2.png

I have so far checked:

  • SMB1 and SMB2 is running (from powershell)
  • File And Printer Sharing is allowed in firewall
  • Tried opening with firewall disabled (same error)
  • Tried using net use from powershell (also error)
  • File And Printer Sharing is allowed in Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings
  • Port 139 is Listening (tested from server and remote)
  • Port 445 is NOT Listening (server and remote), but is allowed in firewall

I have found also two odd issues. The FIle And Printer Sharing is not showing the NIC properties, neither SMB feature in the server Manager:

196994-otherissues.png

I hope to not have to reinstall the server to fix the problem.
Any help is appreciated.

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,567 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. MotoX80 32,736 Reputation points
    2022-04-27T21:18:32.827+00:00

    Just to verify... both servers are members of an Active Directory domain, and the account you are using is an AD account that is a member of the Administrators group on both servers, correct?

    You show the share permissions, but not the folder permissions on D:\share_test. Have you reviewed them? In the Security tab for that folder click on the Advanced button, and then select the Effective Permissions tab. Pick a user account and see what access it reports.

    On the file share server, check the security eventlog for logon errors.

    I don't have access to a 2012 server, but in eventvwr, check in Applications and Services Logs, Microsoft, Windows, SMBServer. See if any related events are in those logs. (I don't know which version of the OS introduced those logs.)

    Verify that Powershell can connect.

    Test-NetConnection -ComputerName YourFileShareComputerName -CommonTCPPort SMB
    

    If this worked 2 days ago, then do a good old reboot on both machines.

    0 comments No comments

  2. Limitless Technology 39,501 Reputation points
    2022-04-28T08:55:49.833+00:00

    Hello

    Thank you for your question and reaching out.

    I can understand you are facing issues while sharing Folder from Server Manager.

    You can also enable amins$ share by enabling File and Printer Sharing (SMB-In) Firewall Rule.

    Go to Control Panel > System ans Security > Windows Defender Firewall > Advance Settings > Inbound Rules. Right click on File and Printer Sharing (SMB-In) from the list and select Enable Rule`. Normally, there are two File and Printer Sharing (SMB-In), one is for Domain profile and one is for Public & Private profile. I'm not sure which profile should be applied, Domain or Public or Private. For me, it's Domain profile.

    Also , please share Admin$ share or Hidden share.

    You need to add the 'admin$' share which is your C:\Windows location.

    Go to C:\windows and right-click --> Properties
    Hit advance sharing
    Click the check box Share this folder
    Enter the name admin$ and hit Permissions
    I would recommend removing 'Everyone' and adding just the users that the PsExec command will use to execute.


    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  3. ticbx 1 Reputation point
    2022-04-28T11:40:31.977+00:00

    Hi, sorry for the late response.

    With more troubleshooting yesterday I found a way to fix the the missing File and Printer Sharing for Microsoft Networks from the NIC adapter properties in this other post.

    After doing this, the issues with sharing folders were also resolved.

    I don't know how it disappeared to begin with. Coincidentally in the same day that this issue with shared folders started the Bitdefender was giving false positives to a software used in the company, no clue if it is related.

    Thanks everyone for the help!

    0 comments No comments