SCSM Exchange Connector Issues

Justin Cron 21 Reputation points
2022-04-27T17:25:45.967+00:00

I really could use some help with the exchange connector 4.1 working within SCSM 2016 - I have pretty much tried way to get this work, from using Exchange Server URL to using Exchange Online and I keep getting this error

197078-image.png

Also including API permissions as well if that can provide any information

197111-image.png

I was hoping I could get some help.

Service Manager
Service Manager
A family of System Center products for managing incidents and problems.
214 questions
0 comments No comments
{count} votes

Accepted answer
  1. SChalakov 10,371 Reputation points MVP
    2022-04-28T07:59:25.487+00:00

    Hi @Justin Cron ,

    I see that you are using the Connector with O365. Did you follow all the steps from the guide regatrding authentication and impersonation, in particular those:

    Recipient Impersonation
    Unless you configure Exchange Connector to allow impersonation for other accounts, Exchange
    Connector can access only the mailbox of the Run As account that is specified in the Create
    Exchange Connector wizard. If you want to have multiple Exchange Connector instances that
    monitor different mailboxes, you must configure Exchange Connector to allow the Run As
    account to impersonate the credentials of the other mailbox recipients

    Also, what about htis hint:

    197275-image.png

    Did you also follow the steps uder "Prerequisites to setup OAuth"?

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)
    Regards
    Stoyan Chalakov

    0 comments No comments

0 additional answers

Sort by: Most helpful