Unable to create azure notification hub

mattbritton 1 Reputation point
2022-04-28T08:44:48.823+00:00

Hi,
I have recently been trying to create a new Azure Notification Hub in a different Directory and Subscription and have been having some issues.
When I created the hub for the first time the deployment went okay but it took a while to show up in the resource group.
Then when I went into the hub, on the overview tab, the name and namespace both said AjaxError. The AjaxError text for the namespace was clickable and takes me to the namespace but in the namespace, the name also says AjaxError and the Notification Hub list says no results.

If I go back into the notification hub and then access policies there are no results. Then if I try to create a policy I get an error "Failed to create authorization rule *name*. Reason: No such host is known. (*****-fabric.nh-svc.azure.com:port).". I've taken out some data from the URL but am happy to provide the rest if required. I also get the no such host is known error with the same URL when I try to delete the notification hub.

When I go to the settings for Apple I get the error message in the screenshot below. It is a similar message for other providers such as Google.

197314-screenshot-2022-04-28-at-093018.png

To get around the issue I have tried making another notification hub in the same directory and subscription but when I made this one the deployment status for creating the hub is "GatewayTimeout" but for creating the namespace the status is "OK". Going into the hub and namespace gives the same issues as the other.

I created another notification hub a few weeks ago and that went completely fine so I went back to the directory and subscription that I made that one in and created another which worked fine as well.

Using a different directory and subscription isn't an option here so if anyone has any ideas as to what the issue is that would be great.
Happy to provide any more information if needed.

EDIT: Some more info
Trying to delete the notification hub via command line returns this error. (some data taken out)
"Error occurred in request., RetryError: HTTPSConnectionPool(host='management.azure.com', port=443): Max retries exceeded with url: /subscriptions/{id}/resourceGroups/{resourceGroup}/providers/Microsoft.NotificationHubs/namespaces/{notificationHubNamespace
?api-version=2017-04-01 (Caused by ResponseError('too many 504 error responses'))"

Azure Notification Hubs
Azure Notification Hubs
An Azure service that is used to send push notifications to all major platforms from the cloud or on-premises environments.
299 questions
{count} votes