Problem with AKS when following tutorial

geoff belair 11 Reputation points

I had previously walked through the tutorial from MS as and it worked about 2 months ago. I walked through the tutorial again today, but it is failing (unable to connect to the test apps, and the certificate also seems to be unable to generate. I get
Normal Issuing 13m cert-manager Issuing certificate as Secret does not exist
Normal Generated 13m cert-manager Stored new private key in temporary Secret resource "tls-secret-7rf2m"
Normal Requested 13m cert-manager Created new CertificateRequest resource "tls-secret-ssg66"
Warning Failed 12m cert-manager The certificate request has failed to complete and will be retried: Failed to wait for order resource "tls-secret-ssg66-3505050538" to become ready: order is in "invalid" state:

If I look at the AKS load balancer insights I see the attached picture, but I cannot find the root cause. There is a message that says: "Some of your load balancing endpoints may be unavailable. Please see the metrics blade for availability information and troubleshooting steps for recommended solutions" Not sure when this worked before, but not now.


Any help would be greatly appreciated.

Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,334 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. risolis 8,241 Reputation points

    Hello @geoff belair

    Thank you for your post.

    I wonder if by any chance you have checked the Resource health status for this resource or the CloudAgent on your AKS enviroment.

    Looking forward to your feedback,

    Best Regards,

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments