Visual Studio 2013 Pro - The online service is not available

Nicolas Moreno 31 Reputation points
2022-04-29T19:28:17.997+00:00

Hello,

Until one week, I cannot log on my Visual Studio 2013 Pro. When I click on "Connect" button, I have the following error: The online service is not available.

I try on 3 others PC (including private one or a new created VM) and I always have the same problem! I try to contact thenical support but I don't have Access Key and chat support cannot give me one (Access Key generator is broken until monday).

Someone can Help me, please?

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,776 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
989 questions
0 comments No comments
{count} votes

Accepted answer
  1. Tianyu Sun-MSFT 28,676 Reputation points Microsoft Vendor
    2022-05-02T02:36:37.367+00:00

    Hello @Nicolas Moreno ,

    Welcome to Microsoft Q&A forum.

    Please try to configure .NET Framework to support strong cryptography to use TLS 1.2 or enable TLS 1.0 from registry.

    For configuring to support strong cryptography > press Windows key + R > type regedit > navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319 > add a new registry entry named SchUseStrongCrypto > set its type to DWord > set its value = 1.(or creating a new registry entry by using PS command)

    For enabling TLS 1.0 > press Windows key + R > type regedit > navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\ > TLS 1.0 > Client > Enabled DWord value 1.

    More details, see this doc: Configure for strong cryptography and this thread: Unable to login to VS 2013 upgrade 5.

    Have a great day.

    Best Regards,
    Tianyu

    • If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
      Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
    20 people found this answer helpful.

4 additional answers

Sort by: Most helpful
  1. BillNew 36 Reputation points
    2022-07-25T16:01:25.907+00:00

    The SchUseStrongCrypto regedit fixed the issue for me.

    Thank you!

    2 people found this answer helpful.

  2. Brijesh Singh 5 Reputation points
    2023-03-31T18:32:21.1066667+00:00

    The SchUseStrongCrypto regedit fixed the issue for me to.

    Thanks

    1 person found this answer helpful.
    0 comments No comments

  3. Henry Rodríguez 5 Reputation points
    2023-07-06T21:45:04.0366667+00:00

    I had same problem, this solution solved it. Thanks for your advice. SOLVED

    1 person found this answer helpful.
    0 comments No comments

  4. Fernando Pinguelo 0 Reputation points
    2023-01-28T18:52:00.3066667+00:00

    My answer is, quit using Microsoft altogether and switch to Java. How absurd it is to add an unnecessary road block to the developer by forcing him/her to log into a server on the Internet just to allow the use of the supposedly free IDE (Community edition) in the local machine. If for whatever reason the Internet is not available or, in my case, if the Microsoft server simply refuses log-ins for whatever fancy reason it has, the developer is completely and hopelessly out of luck and is not even able to view his/her own code.

    The individual who came up with such an idiotic idea to force a remote login to use the local (free) IDE is either completely oblivious of the paralysis he can cause to many developers out there or is a low-IQ idiot who does not have a clue about when to integrate remote machines.

    But I guess I asked for it. I still program using Microsoft now and then besides being aware of the degradation that their products are going through. If one cares, just compare Microsoft Word before the 2013 version and the versions of today. They broke their own rules by placing gigantic tiles on their menus and making much harder to discover features. Also, all applications on Windows have the title bar colors blending with the background, only causing confusion.

    I bet no one at Microsoft will care about this comment. I bet it will be deleted and forgotten forever because this Microsoft generation has much lower IQ than the generation prior 2000.