OfficePP 2019 KMS activation - DNS auto-discovery: KMS name not available

Szunomár Péter 46 Reputation points

Hi All,

On my DNS server is a _vlmcs._tcp SRV record to our KMS server. It has been operating for years, without problem. Now the KMS Autodiscovery fails.

We installed some OPP2019, but they won't be activated. "OSPP.VBS /dstatus" says:
Activation Type Configuration: ALL
DNS auto-discovery: KMS name not available
Activation Interval: 120 minutes
Renewal Interval: 10080 minutes
KMS host caching: Enabled

Case I'm using the "ospp.vbs” /sethst:<FQDN>" option (what i won't, i need to use the dynamic way from DNS), the activation is done without any errors. So the KMS server and the connection seems to be correct, but the DNS can't serve Autodiscovery.

Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
2,062 questions
Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
1,035 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Emi Zhang-MSFT 23,811 Reputation points Microsoft Vendor

    Hi @Szunomár Péter ,
    Try to verify the KMS key in host computer, please follow these steps:

    From an elevated command prompt on the KMS host computer, run the following command:

    cscript slmgr.vbs /dlv all  

    To view information only for Office 2019, specify the Activation ID after the /dlv parameter. For example:

    cscript slmgr.vbs /dlv 70512334-47B4-44DB-A233-BE5EA33B914C  

    Then post the output text here, you can check if the License Status: Licensed.

    Then I suggest you refer to this article about "configure DNS for activating volume licensed versions of Office by using KMS":

    Make sure the DNS is configured correct.

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  2. Limitless Technology 39,501 Reputation points

    Hi there,

    Verify that the KMS activation threshold is met. On the KMS host computer, run Slmgr.vbs and use the /dli command-line option to determine the host’s current count.

    The below thread discusses the same issue and you can try out some troubleshooting steps

    from this and see if that helps you to sort the Issue.
    DNS auto-discover: KMS name not available

    I also suggest you refer to this article about "configure DNS for activating volume licensed versions of Office by using KMS" to check if you have configured the KMS properly.


    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments

  3. Szunomár Péter 46 Reputation points

    Ok Guys, we have the trick in the process.

    After installing the Windows if you use the "slmgr.vbs /skms:<FQDN or IP>" command to set a static KMS server (here it was directly coded in our Windows installer), the Office 2019 won't use anymore the MKS-Autodiscovery DNS records. They just try to use the KMs from Windows.
    In our case, this old server had only licences for Win10, not for OPP2019 (even that is why we want to use the new one, offered from DNS)

    So the solution is: man have to use the "slmgr.vbs /ckms" command to delete the KMS server defined to Windows. "ospp.vbs /remhost" command will not clear it and even "ospp.vbs /skms:<FQDN>" will not overwrite it. That is two different record in registry, but the Office uses the Windows-Record if it exists and an Office-Record doesn't exists.

    After cleared the record, the Offices started to be Licenced. Well done.

    Unfortunately the weight or priority isn't used by clients from _vlmcs._tcp SRV records so i haven't found any way to force the use of DNS instead of registry records.