Can't create a VM

Raymond J Hallquist 21 Reputation points
2022-05-05T03:12:53.79+00:00

no size is available in eastus, northcentralus or southcentralus. An article suggests that I haven't activated a resource provider. I can't figure out which one. I'm trying to create a Standard_B1s.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,531 questions
{count} votes

Accepted answer
  1. vipullag-MSFT 25,861 Reputation points
    2022-05-05T05:12:07.663+00:00

    @Raymond J Hallquist

    Firstly, apologies for any inconvenience this issue may have caused.

    Few VM sizes are currently not available in certain region due to demand (this is the case for many free trial accounts VM sizes). The solution is to create your VM resources in neighboring regions during these periods of high demand.

    There are few other customers who reported similar issue, and redeploying in another region was successful.

    What is Microsoft doing to avoid capacity issues in the future?
    Ensuring capacity for our customers is a top priority for Microsoft and we are working around the clock to deliver on this. The increasing demand for Azure services is evidence of the popularity of Azure, and emphasizes the need to scale up our infrastructure even more rapidly. With that in mind, we are expediting expansion and are improving our resource deployment process to respond to this strong customer demand. We have identified several improvements on how we load-balance under a high resource usage situation, and how to trigger the timely deployment of needed resources. Furthermore, we are increasing our capacity significantly – and will continue to plan for strong customer demand across all of our regions. This September 2021 blog post covers improvements towards delivering a resilient cloud supply chain.

    Hope that helps.

    Please "Accept as Answer" and Upvote if any of the above helped to help others in the community looking for remediation for similar issues.


1 additional answer

Sort by: Most helpful
  1. MartinZ 1 Reputation point
    2022-05-09T18:58:18.033+00:00

    @Raymond J Hallquist Thank you, I had seen your post before, so I tried literally every location. Had one that allowed it to pick with no red marks but when I tried to create it gave that error about picking a different location.

    0 comments No comments