question

KevinChen-3357 avatar image
0 Votes"
KevinChen-3357 asked YutongTie-MSFT edited

In mobile, user is not able to login in the tab.

I am doing sso in bot, and this is i follow example code
https://github.com/microsoft/BotBuilder-Samples/tree/main/samples/javascript_nodejs/46.teams-auth

This is work in PC, but this is not work in IOS and Android.

Is anyone know how to solve this.

office-teams-windows-itprooffice-teams-app-devazure-bot-service
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I guest this problem is that https://token.botframework.com/api/oauth/PostSignInCallback can't redirect to teams app.

II add proxy in my iphone, and I catch the request to "aadcdn.msauth.net".

After I login successful from iphone Microsoft Teams, the login page is closed, but my server don't get any message.

If I use PC Microsoft Teams, my server will get the invoke request and the magic code in vaule.

0 Votes 0 ·

So, Is your issue resolved or are you still looking for any help?
If not resolved, Could you please share the exact error log/console log you are getting/

0 Votes 0 ·

We are setting sso in Microsoft Teams Bot, and have some problem on mobile.
This bot is able to login in Teams on Mac and Windows, but this is not working in iOS and Android.
This is my demo gif in iOS.
https://lh3.googleusercontent.com/J5ejkUzhqwCbs9LYHNEVtu6n-ZZcMrAslzoEraywVDQE0s71RPYd1Ysi1VxtdE3Om5T6ZNkFKZXnqkTA6ZG9cKcx_ePN7-wvW9PiWGzSNiMlKSg-t21tPN9T6WN6goi1AzOExHs4PYM=w2400

This routing is not working at redirect to https://token.botframework.com/api/oauth/PostSignInCallback

Does anyone know how to solve this?

I have added ngrok.io/token.botframework.com in manifest.json

"validDomains": [
"*.ngrok.io",
"token.botframework.com"
],

0 Votes 0 ·

I figure out that sso routing is block at const {OAuthPrompt} = require('botbuilder-dialogs');

I add console.log in continueDialog in source code, and the auth follow doesn't attach this function.
199455-image.png



My bot library is botbuilder-dialogs@4.15.0

0 Votes 0 ·
image.png (55.1 KiB)

I update botbuilder and botbuilder-dialogs to 4.16.0, but this still not works

0 Votes 0 ·

1 Answer

Prasad-MSFT avatar image
0 Votes"
Prasad-MSFT answered Prasad-MSFT commented

We tried to repro the issue with the provided sample, but it worked for us without any error in both Teams Desktop and mobile devices.
Adding the SS below:
Android:
200114-image.png

Could you please try to update your MS teams version and check if it helps?
MS Teams version used for testing:
200104-image.png



image.png (71.2 KiB)
image.png (27.2 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for your help.

I have already updated my Teams app in my Android and iOS device, but it still not works.

Could you provide me your testing code and manifest?

iOS Teams version is V4.7.2

Android Teams version is 1416/1.0.0.2022274402

my iOS device version is 15.4.1
Android version is 12

I follow this guide
https://docs.microsoft.com/en-us/azure/bot-service/bot-builder-authentication?view=azure-bot-service-4.0&tabs=userassigned%2Caadv2%2Ccsharp
and my language is javascript.

0 Votes 0 ·