"PermissionError: [Errno 13] Permission denied" when trying to access a local file for a conda environment

AJV 11 Reputation points
2022-05-08T20:30:50.827+00:00

After Azure ML Studio blocking me from using any compute due to an as-of-yet unresolved authentication error, I moved to using a Jupyter Notebook on my local workstation to try to configure my experiments locally then send the job to an Azure compute cluster. I have two lines of Python that tries to create an environment class by accessing a .yml file on my local computer:

yml_path = r"C:\Users\me\Desktop\azure_training\training_env"
pytorch_env = Environment.from_conda_specification(name='pytorch-1.11-gpu', file_path=yml_path)

This causes the following error:

PermissionError: [Errno 13] Permission denied: 'C:\Users\me\Desktop\azure_training\training_env'

I am unsure of what is causing this. When the file doesn't need to be private, I have solved permission denied issues in the past that resulted from locally run tools such as PostgreSQL by going to the file's properties>>security and adding the user "Everyone" with full control. I tried doing that in this case, but it had no impact. I still get permission denied even though "Everyone" has full control over the file.

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,715 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ramr-msft 17,731 Reputation points
    2022-05-10T02:50:53.773+00:00

    @AJV Thanks for the question. if you don't want to "bake" your personal access token (essentially a password) into your Conda environment file, is to follow Use private Python packages - Azure Machine Learning | Microsoft Learn and connect the authenticated feed with your workspace.

    0 comments No comments