(WSUS) Cannot upgrade Win 10 workstations to 1903 from 1809

Ruben_S 6 Reputation points
2022-05-09T22:33:18.73+00:00

Have to upgrade our environment's workstations from Windows 10 Enterprise Edition 1809 (current build 17763) to 1903 then 1909 and ultimately 2004. Unfortunately I cannot even get the first upgrade to 1903 going successfully. I believe I have everything setup correctly on WSUS:

On WSUS, Options> Products and Classification :
(checked) Windows 10
(checked) Windows 10, 1903 and later
(checked) Windows 10, 1909 and later

(checked) Upgrades

Updates > All updates:

(Approved) Feature update to Windows 10 Version (business & consumer), version 1903 en-us x64
(Approved) Feature update to Windows 10 Version 1909 x64 based system 2019-11 via Enable package

Any upgrade I attempt to approve/apply is categorized as not applicable. I know WSUS is communicating because we are able to do our monthly updates. Any ideas what I'm doing incorrectly?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,600 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Adam J. Marshall 9,121 Reputation points MVP
    2022-05-10T01:41:48.437+00:00

    What Upgrades are being referenced as NEEDED by the clients?

    Look at the Upgrades View (If you haven't created one, use my guide https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-2-computer-groups-update-views/ to create the view)

    Then look at Updates that have the approval of 'Any Except Declined' with the status of 'Failed or Needed'

    Then approve those (uses the approvals method from Part 6 https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-6-selecting-your-test-systems-the-approvals-process/)

    1 person found this answer helpful.
    0 comments No comments

  2. Adam J. Marshall 9,121 Reputation points MVP
    2022-05-10T01:42:29.56+00:00

    Also, do the systems have the latest SSU installed on them? If not, install the SSU and see if that helps.

    1 person found this answer helpful.
    0 comments No comments

  3. Rita Hu -MSFT 9,626 Reputation points
    2022-05-10T02:03:49.043+00:00

    @Ruben_S
    Thanks for your posting on Q&A.

    Agree with @Adam J. Marshall .

    1. Please open RUN the clients and print the winver command and share the picture on this forum.
    2. Please try to install the latest SSU and CUs in the devices and check whether the Feature Update is shown as Needed.

    The feature updates will shown as not applicable if you approved non- needed updates.

    Best regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.