Microsoft Excel 2019 cannot access the file ATPVBAEN.XLAM

Gilbert Noetzel 6 Reputation points
2022-05-10T21:22:35.893+00:00

We are deploying MS Office 2019.
Among a user - this user is unable to open an Excel sheet that utilized Analysis Toolpak - VBA Add-ins. Once the sheet is open the following error appears:

Microsoft Excel cannot access the file c:\xxxxxxxx\ATPVBAEN.XLAM. There are several possible reasons:
1 - the file name or path does not exist
2 - the file is being used by another program
3 - the workbook you are trying to save has the same name as a currently open workbook

All the bullets above are not true as follows:
Bullet 1 - the file is there (C:\Program Files\Microsoft Office\root\Office16\Library\Analysis\ATPVBAEN.XLAM
Bullet 2 - There are no other program using the file
Bullet 3 - There are no other workbook open or used

I do not want to regress the user from Excel 2019 to Excel 2010 where we KNOW it works under 2010.

Anyone has a solution?

Thanks,

Gil

Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,687 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Gilbert Noetzel 6 Reputation points
    2022-12-12T20:55:59.95+00:00

    Update:
    The file ATPVBAEN.XLAM is in the ......\Library\Analysis\ folder. Under "Excel Options" - Add-ins - I see is listed as 'inactive application add-ins'. I tried to check it and it reports : Microsoft Excel cannot access the file....several reason.... File Name or path does not exist (of course it exist...I use file explorer to see it), The file being used by another program - (There are no other program using it), Work book you are trying to save has the same name as a currently open work book...(this is a new file/new work book - trying to add ADD-ins!)

    MS really screwing the community up! I need to have the VBAPackage.bin working ASAP.

    The Visual Basic icon in the Developer's tab is grayed out. I did perform on-line repair - ended up re-entering license key.

    Is there a registery switch or flag that needs to be set or turn on to allow VBA?

    Very frustrating.

    Gil

    1 person found this answer helpful.

  2. Emily Hua-MSFT 27,591 Reputation points
    2022-05-11T02:56:33.683+00:00

    Hi @Gilbert Noetzel

    Can this sheet opened correctly on other computers with Office 2019 installed?
    It's recommended to create a new workbook that uses Data Analysis Tool on this user's machine, and open it to have a check.

    Then I suggest you tried to perform an Online Repair for Office 2019 from Control Panel.

    Please make sure VBA is not disabled.
    You can go to File > Options > Trust Center > Trust Center Settings > Macro Settings, check whther macro is enabled.

    If there is any 3rd-party COM add-in, please go to File > Options > Add-ins > Manage, COM add-ins > Go, temporarily disabled it to avoid any conflict.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



  3. Ben Wiseman 0 Reputation points
    2023-01-31T17:43:11.7+00:00

    Sorry I don't have an answer to your question. I am also having the same issue. Did you ever find a workaround?

    Thanks,

    Ben

    0 comments No comments

  4. jeff insightfinancial.us 0 Reputation points
    2024-01-12T21:47:03.88+00:00

    I spent hours working on this problem and finally found an answer:

    1. When I installed Analysis ToolPak and Analysis ToolPak VBA, the file was save as ATPVBAEN.XLAM.
    2. However, the macro in my workbook created in 2005 referenced ATPVBAEN.XLA.
    3. I simply had to change two references in the macro in my workbook created in 2005 to ATPVBAEN.XLAM by adding an "M"

    Hope that solution works for you.

    Jeff in Virginia

    0 comments No comments