Android SDK instance error while opening Android device manager in Visual Studio

asked 2020-09-02T10:01:04.85+00:00
Karthik Sankaran 96 Reputation points

22143-error.png22211-androidoptions.png22138-microsoftrepositoryplatforms.png

I have installed Visual Studio Enterprise 2019 version 16.1.3 with mobile development features. I am using AMD processor with Windows 10 with Virtualization Technology enabled in BIOS. Have also enabled hyper-v and Windows hypervisor platform. I have attached here all the images of my installation settings and error. Eagerly looking out for solutions and ideas.

22144-microsoftrepositorytools.png22212-microsoftrepositorytools1.png22183-microsoftrepositorytools2.png

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,401 questions
No comments
{count} votes

Accepted answer
  1. answered 2020-09-16T07:57:38.307+00:00
    Karthik Sankaran 96 Reputation points

    The android device manager worked by running the Visual Studio in administrator mode and by setting the path for ANDROID_HOME and ANDROID_SDK_ROOT as the default SDK path( C:\Program File (x86)\Android\android-sdk ).

    No comments

1 additional answer

Sort by: Most helpful
  1. answered 2020-09-03T05:03:24.293+00:00
    Tianyu Sun-MSFT 12,846 Reputation points Microsoft Employee

    Hello KarthikSankaran,

    Thank you for sharing images with me, I noticed that you set the Android SDK Location as C:\Users\XXX\AppData\Local\Android\Sdk. This isn’t the default location of Android SDK, of course, you can customize it but please note, there are some incompatibilities with the Android SDK set by Visual Studio 2019 and Android Studio.

    Not sure if you have installed Android Studio and set the Android SDK under this directory: C:\Users\..... I recommend you go to this directory: C:\Program Files (x86)\Android\android-sdk and copy the related folders and files(Android SDK) from the customized directory to this default directory (or you can change to another customized directory) then set the Android SDK Location to C:\Program Files (x86)\Android\android-sdk from Tools > Options... > Xamarin > Android Settings and try to open Android device manager again.

    Feel free to let me know the result.

    Sincerely,
    Tianyu